none
Unable to add windows nodes to Kubernetes cluster and Containers stuck in "ContainerCreating" status RRS feed

  • Question

  • Hello,

     

    I have followed the guide microsoft guide to add windows nodes to kubernetes cluster(version 1.15.3 and overlay networking solution).

     

    When I am run start.ps1 script, it's getting stuck in "Waiting for the network to be created" . I have tried running the start.ps1 script multiple times and stuck in the same error.

    I also tried to launch it manually as per the troubleshooting guide and I am getting an error "Error registering network: failed to acquire lease: node "frsdocker5" pod cidr not assigned

    I0520 14:41:06.053232   10608 main.go:366] Stopping shutdownHandler...

     

    PS C:> [Environment]::SetEnvironmentVariable("NODE_NAME", "<Windows_Worker_Hostname>")

    PS C:> C:\flannel\flanneld.exe --kubeconfig-file=c:\k\config --iface=<Windows_Worker_Node_IP> --ip-masq=1 --kube-subnet-mgr=1

     


     

    The node is stuck in "Not ready" status in the cluster. I have started the started the start-kubelet.ps1 script manually and the windows node moved to Ready status. But, when I spin up a container, it's stuck in "ContainerCreating" status with the below error.

     

     

     

    Failed create pod sandbox: rpc error: code = Unknown desc = [failed to set up sandbox container "fb1cf5155c28b732effcab24be31785020340ddf749408d78913e0dff87b695a" network for pod "hello": NetworkPlugin cni failed to set up pod "hello_default" network: error while GETHNSNewtorkByName(vxlan0): Network vxlan0 not found, failed to clean up sandbox container "fb1cf5155c28b732effcab24be31785020340ddf749408d78913e0dff87b695a" network for pod "hello": NetworkPlugin cni failed to teardown pod "hello_default" network: failed to find HNSEndpoint fb1cf5155c28b732effcab24be31785020340ddf749408d78913e0dff87b695a_vxlan0: Endpoint fb1cf5155c28b732effcab24be31785020340ddf749408d78913e0dff87b695a_vxlan0 not found]

     

     

     

    Please help me to resolve the issue.

    Wednesday, May 20, 2020 10:00 PM