none
Unable to load mail app with test license token RRS feed

  • Question

  • Hi all,

    I am developing a mail app that does license checks when the app initially loads. I have created and encoded (Base64 and URL) a license for testing. The encoded license token is appended as a query parameter (https://...?et=<encoded license token>) to the Source Location in my app's App Manifest. The mail app is hosted in IIS and installed it in my O365 mailbox using the Exchange Admin Center.

    When I load the app however, I get an error message stating: 'Sorry, but we can't start this app because it isn't set up properly'. Removing the query parameter containing the encoded license token seems to resolve this issue, however I am unable to test my client-side logic for license checks. I have already used the same encoded license token to test the Office App verification service on my server and there have been no errors so I doubt the issue is with the license token.

    Any insights to this would be great appreciated.


    Monday, June 29, 2015 12:44 AM

All replies

  • Hi zcsoriano,

    >> The encoded license token is appended as a query parameter (https://...?et=<encoded license token>) to the Source Location in my app's App Manifest

    In my option, license check is only required for Office store app and we can’t hardcode the et parameter in manifest file. Did you get this error when you publish your mail app? If so, I could help move this thread to the more related forum.

    If I misunderstood you, please feel free to let me know.

    Best Regards,

    Edward


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Tuesday, June 30, 2015 10:18 AM