none
VSDubug message popup appear when I use shortcut which include Shift + Ctrl

    Question

  • VSDubug message popup appear when I use shortcut which include Shift + Ctrl  (like UPPPER CASE Ctrl + Shift + U)

    Even after uninstall and re-install of VS 2015 (enterprise) it still happens


    Bnaya Eshet

    Sunday, September 18, 2016 1:58 PM

Answers

All replies

  • Hi Bnaya Eshet,

    Thanks for your post.

    Could you please tell me what's the VSDebug message? How about testing with a new created project? Does it have the same problem?

    First please check the shortcut was correctly set:

    I did a test in my side using VS2015 Enterprise Update3. I can use the shortcut which include Shift + Ctrl successfully.

    For example, I tested with Shift + Ctrl + U. I selected the code int a; and perform  Shift + Ctrl + U. The int a will be changed to INT A

    So please reset the settings of your Visual Studio at first.(Tools->Import and Export Settings->Reset all Settings)

    Also try to running your Visual Studio in Safe mode to Check whether some add-ins and extensions affect it (devenv /safemode).

    If above suggestion still no help. I think something is wrong with your Visual Studio.  Please install the VS2015 Update3, the latest update of Visual Studio 2015.

    Best Regards,

    Lake Xiao

    Tuesday, September 20, 2016 2:17 AM
    Moderator
  • It was working on my computer too but something went wrong.

    Nothing that I can point to.

    I already tried to reset the setting and even re-install visual studio, nothing help.

    I already tried to debug it with another instance of visual studio hopping to catch first time exception,

    but no exception thrown.

    The shortcut is correct.

    I also post feedback via visual studio + recording of the problem.

    under the title: Failiure Shift + Ctrl keyboard shortcut.

    The error message is :
    VSDebug Message

     Command data:

       Guid = {1494A755-94DE-11D0-8C3F-00C04FC2AAE2}

       GuidId = 12

       CmdID = 48

       Type = 0x00000001

      Flafs = 0x00000070

      Localized name = {Not set}


    Bnaya Eshet

    Tuesday, September 20, 2016 5:37 AM
  • Hi Bnaya Eshet,

    I have some confused about your issue now. From your question, I understand that there was something wrong with the Shift + Ctrl shortcut.

    Does the error message occurred when click the Shift + Ctrl + U shortcut? Do you have another issue?

    If possible, please tell me some more information about your case.

    In addition, I did a research about the error message you shared, I found a document about "Troubleshoot failures of keyboard shortcuts by using three or more keys on Microsoft keyboards ":

    https://support.microsoft.com/en-us/kb/909528

    Best Regards,

    Lake Xiao

    Tuesday, September 20, 2016 6:13 AM
    Moderator
  • It's happens with any shortcut using Shift + Ctrl

    My computer is Surface pro 3.

    It don't seem as hardware problem because it work on other scenarios.

    I checked it with the following code

            static void Main(string[] args)
            {
                while (true)
                {
                    var c = Console.ReadKey(true);
                    Console.WriteLine($@"Shift = {(c.Modifiers & ConsoleModifiers.Shift) == ConsoleModifiers.Shift}
    Control = {(c.Modifiers & ConsoleModifiers.Control) == ConsoleModifiers.Control}
    ");
                }
            }


    Bnaya Eshet

    Tuesday, September 20, 2016 12:51 PM
  • Hi  Bnaya Eshet,

    Was the output Shift and Control as True when click the Shift+Control? If so. I think the windows shortcut shift and control should be fine.

    If it is not a  hardware problem. I think the problem is still in your Visual Studio. How about using another version of Visual Studio like VS2013? Does it have the same issue?

    By the way, to verify whether the cause is in the  Surface pro 3. Can you test it with another Surface pro3.

    If it works well for another Surface. I think the cause is must be in your Visual Studio itself. Repair it and install the VS2015 Update3.

    Best Regards,

    Lake Xiao 


    Wednesday, September 21, 2016 1:47 AM
    Moderator
  • The hardware is fine (it was true).

    I will try to test it on another computer (not Surface because I don't have any available except mine).


    Bnaya Eshet

    Wednesday, September 21, 2016 1:16 PM
  • Hi Bnaya Eshet,

    I did a test in my side using Surface. It can works well for Ctrl+Shift+U. And we have confirmed that your hardware was fine.

    So I think the cause would be in your Visual Studio.  Please try to install the VS2015 Update3, the latest update of Visual Studio 2015. After that, try to create a new C# console application. Write a simple code like int a, Select the int a and perform Ctrl+Shift+U. How about the test result?

    Best Regards,

    Lake Xiao

    Thursday, September 22, 2016 1:33 AM
    Moderator
  • Bnaya,

    Looks like you have EnableVSIPLogging enabled. See Using EnableVSIPLogging to identify menus and commands

    For Visual Studio 2015 you can remove it from the following registry key: HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\14.0\General



    Sergey Vlasov | Vlasov Studio | Visual Studio add-ins, extensions and tools

    • Marked as answer by Bnaya Eshet Sunday, September 25, 2016 8:16 AM
    Friday, September 23, 2016 2:10 PM
  • Thanks

    it solve the problem


    Bnaya Eshet

    Sunday, September 25, 2016 8:16 AM