locked
IIS7 Microsoft.Jet.OLEDB.4.0' Not Registered RRS feed

  • Question

  • I have installed IIS7 running on Vista 64 bit OS. But when accessing web pages with a connection string to access.mdb I get an error message - Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine. I have had this problem with VB2008 but can be resolved by resetting the CPU to x86.

    By lengthy searching I came across the following code:

    [cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 0

    %SYSTEMROOT%\Microsoft.NET\Framework64\v2.0.50727\aspnet_regiis.exe -i ]

    However this does not solve the problem.

     

    Help would be appreciated

    Thursday, March 4, 2010 11:03 PM

Answers

  • You need to run Access database applications in a 32 bit asp.net application pool.  You do that via your IIS admin.

    Open IIS manager, select Application Pools, select the application pool you are using, click on Advanced Settings in the right-hand menu.  Under General, set "Enable 32-Bit Applications" to "True".
    • Marked as answer by latoc Thursday, March 4, 2010 11:30 PM
    Thursday, March 4, 2010 11:05 PM

All replies

  • You need to run Access database applications in a 32 bit asp.net application pool.  You do that via your IIS admin.

    Open IIS manager, select Application Pools, select the application pool you are using, click on Advanced Settings in the right-hand menu.  Under General, set "Enable 32-Bit Applications" to "True".
    • Marked as answer by latoc Thursday, March 4, 2010 11:30 PM
    Thursday, March 4, 2010 11:05 PM
  • Excellent many thanks now working.

    latoc 

    Thursday, March 4, 2010 11:30 PM
  • Thanks. Working.
    Friday, June 17, 2011 1:34 PM
  • This Solved my Problem , Thanks

     

    Raj Gujar


    R A J
    Wednesday, December 14, 2011 2:54 PM
  • You little ripper, THANKS!@
    Saturday, March 3, 2012 7:50 AM
  • Thank you!
    Monday, April 7, 2014 8:33 PM