locked
Addin built for Outlook 2007 not working in 2010 RRS feed

  • Question

  • We have an addin built in .Net using Outlook IAs on a dev machine that had outllok 2007. The addin installs a toolbar on the main explorer with a button. When the button is clicked a form loads with properties from the current selected mail in the explorer and performs some action.

    On the clicnt they are now upgrading to 2010, and the toolbar is not showing up. It does not look like the addin is even showing up anywhere.

    We also trigger the same form when a reply action happens. But in 2010, nothing happens.

     

    • Moved by John Qiao Tuesday, February 1, 2011 2:39 AM (From:Team Foundation Server - Build Automation)
    Monday, January 31, 2011 11:10 PM

Answers

  • In 2010 any Explorer command bar controls you create are relegated to the Add-Ins tab. Is your UI showing there? If not, is your addin actually running?
     
    You need to check in the Trust Center and see if it is. If not you need to do Fusion debugging to see why the addin isn't being loaded. See this article on Fusion debugging: http://blogs.msdn.com/b/vsod/archive/2008/04/22/troubleshooting-com-add-in-load-failures.aspx
     
    In general, except for 64-bit Outlook 2010, any addin you had running in 2007 should run and work in 2010 without change if the addin has no other problems.

    --
    Ken Slovak
    MVP - Outlook
    http://www.slovaktech.com
    Author: Professional Programming Outlook 2007
     
     
    "Arunnayar" <=?utf-8?B?QXJ1bm5heWFy?=> wrote in message news:210a4737-2de9-435f-8248-939472453316...

    We have an addin built in .Net using Outlook IAs on a dev machine that had outllok 2007. The addin installs a toolbar on the main explorer with a button. When the button is clicked a form loads with properties from the current selected mail in the explorer and performs some action.

    On the clicnt they are now upgrading to 2010, and the toolbar is not showing up. It does not look like the addin is even showing up anywhere.

    We also trigger the same form when a reply action happens. But in 2010, nothing happens.

     


    Ken Slovak MVP - Outlook
    • Marked as answer by Bessie Zhao Tuesday, February 8, 2011 9:34 AM
    Tuesday, February 1, 2011 2:37 PM