locked
Azure Stack Registration Failed RRS feed

  • Question

  • I am having some trouble registering azure stack via the RegisterWithAzure.ps1 script from github.  It is saying that the version i have 1.0.170331.1. 

    .\RegisterWithAzure.ps1 -azureSubscriptionId "xxxxx" -azureDirectoryTenantName "XXX.onmicrosoft.com" -azureAccountId "azurestack@XXXX.onmicrosoft.com" 

    VERBOSE: Loading module from path 'C:\CloudDeployment\ECEngine\EnterpriseCloudEngine.psd1'.
    VERBOSE: Removing the imported "Test-EceInterface" function.
    VERBOSE: Loading module from path 'C:\CloudDeployment\ECEngine\EnterpriseCloudEngine.psm1'.
    VERBOSE: Importing cmdlet 'Set-EceSecret'.
    VERBOSE: Importing cmdlet 'Get-EceConfiguration'.
    VERBOSE: Importing cmdlet 'Get-ActionProgress'.
    VERBOSE: Importing cmdlet 'Get-JsonTemplate'.
    VERBOSE: Importing cmdlet 'Invoke-EceAction'.
    VERBOSE: Importing cmdlet 'Join-RoleTemplate'.
    VERBOSE: Importing cmdlet 'Import-EceCustomerConfiguration'.
    VERBOSE: Importing cmdlet 'Set-RoleDefinition'.
    VERBOSE: Exporting cmdlet 'Set-EceSecret'.
    VERBOSE: Exporting cmdlet 'Get-EceConfiguration'.
    VERBOSE: Exporting cmdlet 'Get-ActionProgress'.
    VERBOSE: Exporting cmdlet 'Get-JsonTemplate'.
    VERBOSE: Exporting cmdlet 'Invoke-EceAction'.
    VERBOSE: Exporting cmdlet 'Join-RoleTemplate'.
    VERBOSE: Exporting cmdlet 'Import-EceCustomerConfiguration'.
    VERBOSE: Exporting cmdlet 'Set-RoleDefinition'.
    VERBOSE: Importing cmdlet 'Get-ActionProgress'.
    VERBOSE: Importing cmdlet 'Get-EceConfiguration'.
    VERBOSE: Importing cmdlet 'Get-JsonTemplate'.
    VERBOSE: Importing cmdlet 'Import-EceCustomerConfiguration'.
    VERBOSE: Importing cmdlet 'Invoke-EceAction'.
    VERBOSE: Importing cmdlet 'Join-RoleTemplate'.
    VERBOSE: Importing cmdlet 'Set-EceSecret'.
    VERBOSE: Importing cmdlet 'Set-RoleDefinition'.
    VERBOSE: Loading module from path 'C:\CloudDeployment\ECEngine\.\bin\CloudEngine.Cmdlets.dll'.
    VERBOSE: Importing cmdlet 'Set-EceSecret'.
    VERBOSE: Importing cmdlet 'Get-EceConfiguration'.
    VERBOSE: Importing cmdlet 'Get-ActionProgress'.
    VERBOSE: Importing cmdlet 'Get-JsonTemplate'.
    VERBOSE: Importing cmdlet 'Invoke-EceAction'.
    VERBOSE: Importing cmdlet 'Join-RoleTemplate'.
    VERBOSE: Importing cmdlet 'Import-EceCustomerConfiguration'.
    VERBOSE: Importing cmdlet 'Set-RoleDefinition'.
    VERBOSE: Loading module from path 'C:\CloudDeployment\ECEngine\TestEceInterface.ps1'.
    VERBOSE: Dot-sourcing the script file 'C:\CloudDeployment\ECEngine\TestEceInterface.ps1'.
    VERBOSE: Loading module from path 'C:\CloudDeployment\ECEngine\EnterpriseCloudEngine.psm1'.
    VERBOSE: Importing cmdlet 'Set-EceSecret'.
    VERBOSE: Importing cmdlet 'Get-EceConfiguration'.
    VERBOSE: Importing cmdlet 'Get-ActionProgress'.
    VERBOSE: Importing cmdlet 'Get-JsonTemplate'.
    VERBOSE: Importing cmdlet 'Invoke-EceAction'.
    VERBOSE: Importing cmdlet 'Join-RoleTemplate'.
    VERBOSE: Importing cmdlet 'Import-EceCustomerConfiguration'.
    VERBOSE: Importing cmdlet 'Set-RoleDefinition'.
    VERBOSE: Exporting function 'Test-EceInterface'.
    VERBOSE: Exporting cmdlet 'Get-ActionProgress'.
    VERBOSE: Exporting cmdlet 'Get-EceConfiguration'.
    VERBOSE: Exporting cmdlet 'Get-JsonTemplate'.
    VERBOSE: Exporting cmdlet 'Import-EceCustomerConfiguration'.
    VERBOSE: Exporting cmdlet 'Invoke-EceAction'.
    VERBOSE: Exporting cmdlet 'Join-RoleTemplate'.
    VERBOSE: Exporting cmdlet 'Set-EceSecret'.
    VERBOSE: Exporting cmdlet 'Set-RoleDefinition'.
    VERBOSE: Importing cmdlet 'Get-ActionProgress'.
    VERBOSE: Importing cmdlet 'Get-EceConfiguration'.
    VERBOSE: Importing cmdlet 'Get-JsonTemplate'.
    VERBOSE: Importing cmdlet 'Import-EceCustomerConfiguration'.
    VERBOSE: Importing cmdlet 'Invoke-EceAction'.
    VERBOSE: Importing cmdlet 'Join-RoleTemplate'.
    VERBOSE: Importing cmdlet 'Set-EceSecret'.
    VERBOSE: Importing cmdlet 'Set-RoleDefinition'.
    VERBOSE: Importing function 'Test-EceInterface'.
    D:\AzureStack_Installer\AzureStack-Tools-master\Registration\RegisterWithAzure.ps1 : Script only applicable for Azure Stack builds 1.0.170501.1 or later
    At line:1 char:1
    + .\RegisterWithAzure.ps1 -azureSubscriptionId "xxxxx ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,RegisterWithAzure.ps1

    i tried commenting out the pre-req version check section but it fails on 

    VERBOSE: GET https://management.azure.com/tenants?api-version=2016-02-01 with 0-byte payload
    VERBOSE: received 116-byte response of content type application/json; charset=utf-8
    VERBOSE: GET https://graph.windows.net/myOrganization/oauth2PermissionGrants?$top=1&api-version=1.5 with 0-byte payload
    VERBOSE: received 1749-byte response of content type application/json;odata=minimalmetadata;streaming=true;charset=utf-8
    VERBOSE: GET https://graph.windows.net/myOrganization/tenantDetails?api-version=1.5 with 0-byte payload
    VERBOSE: received 3849-byte response of content type application/json;odata=minimalmetadata;streaming=true;charset=utf-8
    VERBOSE: Calling Configure-BridgeIdentity.ps1
    D:\AzureStack_Installer\AzureStack-Tools-master\Registration\RegisterWithAzure.ps1 : A parameter cannot be found that matches parameter name 'RefreshToken'.
    At line:1 char:1
    + .\RegisterWithAzure.ps1 -azureSubscriptionId "802dffbb-2e3b-431d-981a ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidArgument: (:) [RegisterWithAzure.ps1], ParameterBindingException
        + FullyQualifiedErrorId : NamedParameterNotFound,RegisterWithAzure.ps1

    help would be greatly appreciated!

    thanks

    Paul

    Monday, August 14, 2017 2:26 AM

Answers

  • Looks like you are running TP3. ASDK is out now, TP3 is not supported anymore.
    Download the new bits here : https://azure.microsoft.com/en-us/overview/azure-stack/development-kit/

    Run this  if you're not sure which version you have.

    if ((test-path '\\su1fileserver\SU1_Infrastructure_1\1.0.170627.1')){'ASDK'} else {'TP3 or earlier'} 


    Cheers,

    Ruud
    Twitter:    Blog: AzureStack.Blog  LinkedIn:    
    Note: Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by MrCapper Monday, August 14, 2017 10:29 AM
    Monday, August 14, 2017 7:04 AM

All replies

  • Looks like you are running TP3. ASDK is out now, TP3 is not supported anymore.
    Download the new bits here : https://azure.microsoft.com/en-us/overview/azure-stack/development-kit/

    Run this  if you're not sure which version you have.

    if ((test-path '\\su1fileserver\SU1_Infrastructure_1\1.0.170627.1')){'ASDK'} else {'TP3 or earlier'} 


    Cheers,

    Ruud
    Twitter:    Blog: AzureStack.Blog  LinkedIn:    
    Note: Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by MrCapper Monday, August 14, 2017 10:29 AM
    Monday, August 14, 2017 7:04 AM
  • Thanks Ruud, you were correct. currently installing ADSK now. 


    Monday, August 14, 2017 10:30 AM