none
Windows Store App

    Question

  • System.Security.SecurityException
    Designer could not be started because of a permissions issue on the drive to which it is installed. Please check the permissions of the folder before trying to start the designer.
    Friday, December 18, 2015 8:00 PM

Answers

  • Hi Haseeb Butt,

    You can find answer for your problem on this MSDN forum thread:
    https://social.msdn.microsoft.com/Forums/vstudio/en-US/388dd1c5-ca01-4538-baa8-7555100e4f80/visual-studio-12-designer-could-not-be-started-because-of-a-permissions-issue?forum=vseditor

    Best regards!
    (If this was helpful for you, vote for it and propose it as an answer)

    Friday, December 18, 2015 8:06 PM
  • Hi Haseeb,

    I think you could go through the workaround which shared by maeneak in the following link:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/388dd1c5-ca01-4538-baa8-7555100e4f80/visual-studio-12-designer-could-not-be-started-because-of-a-permissions-issue?forum=vseditor


    And give full control for the 'Reference Assemblies' directory in both 'Program Files' and 'Program Files (x86)' with following steps:

    1.Select the folder in Windows Explorer, right-click and select 'Properties'
    2.Click the 'Security' tab then click the 'Advanced...' button
    3.At the top of the new window there should 'Name' and 'Owner'. Next to owner click the 'Change' link.
    4.In the new window make sure you have your local computer selected under 'From this location:'. If not click 'Locations...' and select your local computer then click 'OK'.
    5.In the textbox under 'Enter the object name to select, type 'Users' and click 'Check Names...'
    6.Click 'OK'
    7.At the top of the page check the option 'Replace owner on subcontainers and objects'. Click 'Apply'. You may be prompted to shut the properties dialog to apply the ownership changes, if so close all dialogs then repeat steps 1 and 2.
    8.On the 'Permissions' tab select 'Users' and click 'Edit'.
    9.Select 'Full Control' then click 'OK'

    Best Regards,

    Lake Xiao

    Monday, December 28, 2015 9:50 AM
    Moderator

All replies

  • Hi Haseeb Butt,

    You can find answer for your problem on this MSDN forum thread:
    https://social.msdn.microsoft.com/Forums/vstudio/en-US/388dd1c5-ca01-4538-baa8-7555100e4f80/visual-studio-12-designer-could-not-be-started-because-of-a-permissions-issue?forum=vseditor

    Best regards!
    (If this was helpful for you, vote for it and propose it as an answer)

    Friday, December 18, 2015 8:06 PM
  • Hi Haseeb,

    I think you could go through the workaround which shared by maeneak in the following link:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/388dd1c5-ca01-4538-baa8-7555100e4f80/visual-studio-12-designer-could-not-be-started-because-of-a-permissions-issue?forum=vseditor


    And give full control for the 'Reference Assemblies' directory in both 'Program Files' and 'Program Files (x86)' with following steps:

    1.Select the folder in Windows Explorer, right-click and select 'Properties'
    2.Click the 'Security' tab then click the 'Advanced...' button
    3.At the top of the new window there should 'Name' and 'Owner'. Next to owner click the 'Change' link.
    4.In the new window make sure you have your local computer selected under 'From this location:'. If not click 'Locations...' and select your local computer then click 'OK'.
    5.In the textbox under 'Enter the object name to select, type 'Users' and click 'Check Names...'
    6.Click 'OK'
    7.At the top of the page check the option 'Replace owner on subcontainers and objects'. Click 'Apply'. You may be prompted to shut the properties dialog to apply the ownership changes, if so close all dialogs then repeat steps 1 and 2.
    8.On the 'Permissions' tab select 'Users' and click 'Edit'.
    9.Select 'Full Control' then click 'OK'

    Best Regards,

    Lake Xiao

    Monday, December 28, 2015 9:50 AM
    Moderator