Database Mail RRS feed

  • Question

  • After browsing the web and reading countless articles I decided I might as well ask for some help.  I'm running a system with Windows Server 2003 and Sql Server 2005 SP2.  I'm trying to configure Sql Server 2005 to notify me when backup jobs fail via Database Mail.  Unfortunately it has been a nightmare trying to get database mail to actually send a test mail.

    Using the same smtp server, SSL enabled setting, and account name and password for the smtp server to authenticate against I have been able to send test e-mails through Outlook Express, however I cannot in database mail.  Connecting to the smtp server through telnet appears to work as well, however I am stuck looking at a blank screen and charcters don't appear when I type so I haven't actually tested sending anything.  I can however at least connect to the smtp server.  When trying to send a test email through Database Mail I continue to receive the same error message, Cannot send mails to mail server (The operation has timed out.).

    I have tested Database Mail with both the public (guest) and a private (added it to the DatabaseMailRole) account.  DatabaseMailRole didn't come pre-configured in Sql Server 2005 so I added it after reading some articles.  I fear however there may be more settings or configuration necessary that I am unaware of.  Looking at the stored procedures it appears as though everything is accounted for.

    *In case anyone asks the same questions I see everywhere else, yes Databse Mail is enabled, yes Service Broker is enabled.

    I may be doing something wrong or misunderstanding how Database Mail differs from Outlook Express in sending mail, but any help would be appreciated.
    Tuesday, January 13, 2009 4:46 PM

All replies

  •  First you config SMTP
    Then GOTO

    Tuesday, January 20, 2009 11:09 AM
  • Here's a link to SQL Server BOL for configuring database mail. Does this complete successfully for you?







    Joe Webb, SQL Server MVP | http://weblogs.sqlteam.com/joew/
    Monday, January 26, 2009 1:03 PM