"The maximum report processing jobs limit configured by your system administrator has been reached."


  • I am using VS 2005 Beta2. My website (C#, ASP.NET 2.0) worked ok. But after I run it several times,  i got an exception when loading the report ( MyReport.load(reportPath) ):
    "The maximum report processing jobs limit configured by your system administrator has been reached."

    Then I restart my pc, and it works again.

    Can anyone tell me what is the problme in my project? Do I need to configure anything? Thanks!


    Friday, August 12, 2005 6:38 PM


All replies

  • Hello Auhe,

    Do you have code to close or dispose the Report Document (MyReport in your case)?

    It sounds like you have multiple report documents open with the report engine. 

    Here is a link to the online help that talks about how to optimize scalability:


    Keith - Business Objects
    Tuesday, August 16, 2005 5:27 PM
  • My users have been receiving this error intermittently ever since we upgraded to Crystal Enterprise XI and Crystal Reports XI. I'm using the same ASP.Net App and C# code, but have replaced the .dll refrences to use the new Business Object managed framework assemblies. I never had this problem with Crystal X. Are there settings somewhere that can be changed to fix this?
    Friday, September 09, 2005 3:28 PM
  • Basically the error means that there is too much load on the reporting engine.  Starting in v10 (suprised you haven't seen this in v10,, or there is more load now), the reporting engine was optimized for greatest report throughput.  There are specific reg keys that control this optimization. 

    By default, the print job limit is set to 75 print jobs.  When a load is placed on the application it can hit the 75 print jobs and 
    cause the above error.
    Report Objects stored in Sessions would be counted as a PrintJob.
    Main reports would count as a PrintJob.
    Subreports would each count as a PrintJob.
    The print job limit is controlled by the following reg key:
    You can try increasing this number to stop the error from happening.  This may stop the error from occurring temporarily but as load increases, you find this error will start to occur again.  You are better to look at scaling your application by adding more hardware to the system.

    o not increase it more than necessary since it can degrade the machines performance.

    WARNING: Any modification made to the registry must be made carefully as it can cause your system to fail.
    • Proposed as answer by neonprimetime Tuesday, July 08, 2008 5:33 PM
    Tuesday, October 04, 2005 11:06 PM
  • The link provided not longer exist.  Here is the new link to BO.


    Don't forget to do a myreport.close and then do a myreport.dispose for the Report Document.

    Just as a note raising the PrintJobLimit from the default of 75 to ?  will not prevent the error from occurring.  You must close and dispose the reportdocument.


    • Proposed as answer by neonprimetime Tuesday, July 08, 2008 5:34 PM
    Saturday, February 25, 2006 6:25 PM
  • Here is my blog post and the approach we use is listed there.



    Wednesday, July 18, 2007 7:33 AM

    I'm passing the same problem. Any aditional help?
    • Proposed as answer by a_jed Tuesday, July 08, 2008 12:24 AM
    Thursday, October 18, 2007 6:27 PM

    I have been using Crystal since it was owned by Seagate Software.  Over the last 10 years, I've seen it's reliablity and scalablity decline.  The IDE addin is buggy, the report engine is lacking and the deployment is a royal pain.  Their support is laughable (as anyone who has tried to call them for it can attest).  I'm really sad to see it slip into the state it's in now since I've been an avid user for so long.  The fact of the matter is that it's an aging product which simply isnt keeping pace with the new development platforms available to developers.  A prime example is it's inablity to deal with nullable types.


    Just this year our company has decided to no longer develop on the Crystal Reports platform.  I'm will not promote any other products, I will however offer a suggestion to the community.  Avoid COM Interop at all costs.  There are an increasing number of very good reporting packages that are 100% .Net, no interop required.  Some are even able to convert some (not likley all) of your Crystal .rpt files to their format.


    Thursday, April 24, 2008 3:44 PM
  • I also faced same problem but I did not restarted PC. Instead just we have to delete some report files from temp folder(C:\Documents and Settings\YourUsername\Local Settings\Temp) with the extension rpt. It worked for me...
    • Proposed as answer by nileshgite Tuesday, November 17, 2009 8:18 PM
    Sunday, April 05, 2009 1:42 PM
  • Hi all,

    I have also had problems with this. I have raised the maximum number of jobs at first, but that did not work for very long, as the problems returned when the application got used more intensively.

    As of now it seems I have solved it, by removing the Dispose() calls and placing the whole Crystal Document object in a using() statement.

    I have not seen this exception since this change, although I can't guarantee anything.

    See my blog for details.



    ----- http://jepsonsblog.blogspot.com -----
    Tuesday, January 04, 2011 8:26 PM