locked
Report viewer is not rendering RRS feed

  • Question

  • User-1735187953 posted

    Hi,

    Im using Reportview in my application, pls verify the web.config

    <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        <handlers>
           
         
         <add name="ReportViewerWebControlHandler" preCondition="integratedMode" verb="*" path="Reserved.ReportViewerWebControl.axd" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
        </handlers>
       
      </system.webServer>
    
    
     <compilation batch="true" debug="true" targetFramework="4.0">
          <assemblies>
            <add assembly="System.Web.Extensions.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
            <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.DirectoryServices, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" /> <add assembly="Microsoft.ReportViewer.Common, Version=10.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="Microsoft.Build.Framework, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <add assembly="System.Management, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
            <!--reports-->
            <add assembly="System.Data.Entity, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.Data.Entity.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" />
            <add assembly="System.DirectoryServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" />
          </assemblies>
          <buildProviders>
            <add extension=".rdlc" type="Microsoft.Reporting.RdlBuildProvider, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
            <add extension=".edmx" type="System.Data.Entity.Design.AspNet.EntityDesignerBuildProvider" />
          </buildProviders>
        </compilation>
    
    
     <httpHandlers>
         
          <add path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" validate="false" />
        
        </httpHandlers>

     


     The problem is the report is not rendering at all.. While go thru the Viewsource, it contains exception message as:

    <noscript>
    &nbsp;Your browser does not support scripts or has been configured not to allow scripts.
    </noscript><span id="ctl00_ContentPlaceHolder1_ReportViewer_ReportViewer"><div id="ctl00_ContentPlaceHolder1_ReportViewer" onclick="if ($get(&#39;ctl00_ContentPlaceHolder1_ReportViewer_ctl04&#39;) != null &amp;&amp; $get(&#39;ctl00_ContentPlaceHolder1_ReportViewer_ctl04&#39;).control != null) $get(&#39;ctl00_ContentPlaceHolder1_ReportViewer_ctl04&#39;).control.HideActiveDropDown();" onactivate="if ($get(&#39;ctl00_ContentPlaceHolder1_ReportViewer_ctl04&#39;) != null &amp;&amp; $get(&#39;ctl00_ContentPlaceHolder1_ReportViewer_ctl04&#39;).control != null) $get(&#39;ctl00_ContentPlaceHolder1_ReportViewer_ctl04&#39;).control.HideActiveDropDown();" style="height:400px;width:100%;">
    <div id="ctl00_ContentPlaceHolder1_ReportViewer_HttpHandlerMissingErrorMessage" style="border-color:Red;border-width:2px;border-style:Solid;padding:10px;display:none;overflow:auto;font-size:.85em;">
    <h2>
    Report Viewer Configuration Error
    </h2><p>The Report Viewer Web Control HTTP Handler has not been registered in the application&#39;s web.config file. Add &lt;add verb=&quot;*&quot; path=&quot;Reserved.ReportViewerWebControl.axd&quot; type = &quot;Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a&quot; /&gt; to the system.web/httpHandlers section of the web.config file, or add &lt;add name=&quot;ReportViewerWebControlHandler&quot; preCondition=&quot;integratedMode&quot; verb=&quot;*&quot; path=&quot;Reserved.ReportViewerWebControl.axd&quot; type=&quot;Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a&quot; /&gt; to the system.webServer/handlers section for Internet Information Services 7 or later.</p>

    Please help me in this regard.. 
    Thanks.

     

    Monday, April 29, 2013 12:04 AM

Answers

  • User1815411410 posted

    hi there,

    have you had a chance to try it from the other browser? does it work?

    Would you please try to browse to it via the server browser? does it make any differences?

    I suspect that the issue is with your SSRS server and you need to contact your host provider to solve it

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, April 30, 2013 2:13 AM

All replies

  • User-1716253493 posted

    1. check maybe there is wrog tag in your page

    2. trust the site in your browser security setting

    Monday, April 29, 2013 2:21 AM
  • User1815411410 posted

    hi there,

    have you had a chance to try it from the other browser? does it work?

    Would you please try to browse to it via the server browser? does it make any differences?

    I suspect that the issue is with your SSRS server and you need to contact your host provider to solve it

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, April 30, 2013 2:13 AM