none
Prevent VSTO project upgrade RRS feed

  • Question

  • Is there any way to use VS2010 for developing an excel AddIn using VSTO 2? As I understand the vsto runtime to use depends on installed office version, not on the VS version being used.

    I would relly would like to upgrade the solution to VS2010, but in the production environment only VSTO 2 is installed.

    Thanks for the help.


    F.M.
    Friday, December 2, 2011 11:29 AM

Answers

  • Hi Mihaly

    VSTO 2010 can only developer solutions for Office 2007 or Office 2010, and these target much later versions of the .NET Framework. so the answer is no, you can't develop a VSTO solution that targets Office 2003 and .NET Framework 2.0 in VS 2010.


    Cindy Meister, VSTO/Word MVP
    Saturday, December 3, 2011 10:52 PM
    Moderator