none
Can't install .NET Framework 4 on my Windows XP RRS feed

  • Question

  • I tried to install .NET Framework 4 for my windows XP, but when I try to install it I get this

    KB2836939v3 does not apply, or is blocked by another condition on your computer.

    Could this be happening because I have Microsoft .NET Framework 3.5 SP1 on my device?

    Any suggestion?

    Thank You

    Tuesday, January 30, 2018 9:34 PM

All replies

  • Hi,

    .NET Framework 4, 4.5.x, 4.6.x, and 4.7.x is not compatible each other, i.e. they cannot coexist in one computer.
    Do you have .NET Framework 4.5.x, 4.6.x, or 4.7.x in your computer?  If so, uninstall it and install 4.

    Regards,

    Ashidacchi

    Wednesday, January 31, 2018 6:14 AM
  • Hi,

    Welcome to MSDN forum.

    >>KB2836939v3 does not apply, or is blocked by another condition on your computer.

    What you installed is the update for .net framework 4, please install The .NET Framework 4 firstly. If you have installed .net framework 4, go to Program and Features, scroll down to Microsoft.Net Framework 4 Client Profile, right click it->change->repair it, and then install the update.

    https://docs.microsoft.com/en-us/dotnet/framework/install/on-windows-xp

    If you still have problems about it, please feel free to let me know.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, January 31, 2018 7:02 AM