locked
Apache Bridge error RRS feed

  • Question

  • Hi All,

    Iam posting data to rest service I am getting below error from service.any suggestions

    I am using wcf-custom adapter.

    Tuesday, February 2, 2016 10:19 AM

Answers

  • Ah, ok.  So, the problem is still on the WebLogic side but is being caused by the flood generated by your BizTalk app.

    Since you BizTalk app is much faster then the WebLogic app, you need to throttle you calls to a level it can handle.

    To address this through configuration, you have basically two options:

    • Set the Send Port to Ordered Delivery.  This will effectively serialize the calls, meaning there will be only 1 at a time.
    • Create a BizTalk Host & Instance for this Send Port and set it's MaxWorkderThreads to to a level WebLogic can handle.
    • Marked as answer by BizTalk1234 Tuesday, February 2, 2016 7:03 PM
    Tuesday, February 2, 2016 3:47 PM
    Moderator
  • Hi All,

    Iam posting data to rest service I am getting below error from service.any suggestions

    I am using wcf-custom adapter.

    Well! A quick search on the error "no backend server available for connection timed out after 10 seconds" is not a biztalk error but the error thrown from weblogic.

    It is a bug or configuration issue at weblogic side and you have to go back to the team and inquire about this error.

    "

    It is a known WebLogic bug (CR220685) with the following explanation:

    WebLogic Server no longer retries using a new connection when the following are all true:

    • Idempotent is set to OFF.
    • A recycled connection is being used.
    • The backend server is not responsive.

    The customer needs to contact WebLogic to remedy this problem.

    "

    Show them these blogs:

    http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec499824.aspx

    http://oracletechdba.blogspot.in/2014/10/errorfailure-of-server-apache-bridgeno.html


    Rachit Sikroria (Microsoft Azure MVP)

    • Marked as answer by BizTalk1234 Wednesday, February 3, 2016 5:09 AM
    Tuesday, February 2, 2016 7:08 PM
    Moderator

All replies

  • Hi Ram,

    Thank you for posting on MSDN forum.

    Your error is not very much clear and readable. Please edit your question with readable format.

    And have you tried to post your request using SOAP-UI tool, Please try and see if it is working.


    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Tuesday, February 2, 2016 10:28 AM
    Moderator
  • Hi kamlesh,

    I have posted the xml in postman tool getting the same error


    • Edited by BizTalk1234 Tuesday, February 2, 2016 11:09 AM
    Tuesday, February 2, 2016 11:07 AM
  • Hi,

    First of all make sure the service that you are trying to post data is up and running. This error seems like your service is down/not available.

    Please indicate "Mark as Answer" or "Mark as Helpful" if this post has answered the question

    Regards

    Rahul Madaan

    biztalkvillage.blogspot.com

    Tuesday, February 2, 2016 11:38 AM
  • It is very clear from the response that the problem is on the WebLogic side.

    You need to contact the owner of that server and work work with them to resolve the problem.  BizTalk/WCF is merely reporting the error, not causing it.

    Tuesday, February 2, 2016 12:46 PM
    Moderator
  • Hi Jhon,

    Actually I have posted 2500 records then it is working fine

    If I post more than that I ma getting above error.

    Is this something problem with processing time on server side ?

    because in adapter level I have mentioned 10 minutes time(close timeout).

    Thanks.

    Tuesday, February 2, 2016 1:12 PM
  • Ah, ok.  So, the problem is still on the WebLogic side but is being caused by the flood generated by your BizTalk app.

    Since you BizTalk app is much faster then the WebLogic app, you need to throttle you calls to a level it can handle.

    To address this through configuration, you have basically two options:

    • Set the Send Port to Ordered Delivery.  This will effectively serialize the calls, meaning there will be only 1 at a time.
    • Create a BizTalk Host & Instance for this Send Port and set it's MaxWorkderThreads to to a level WebLogic can handle.
    • Marked as answer by BizTalk1234 Tuesday, February 2, 2016 7:03 PM
    Tuesday, February 2, 2016 3:47 PM
    Moderator
  • Hi Jhon,

    I am sending whole xml at a time to rest service, means I am sending 3000 records to rest service at a time 

    and after all validation biztalk will get the response.

    I have checked and maxworkerthreads count is 25

    Thanks

    Tuesday, February 2, 2016 6:03 PM
  • To clarity, you are sending 2500 'records' in one single transaction, so 1 big message, not 2500 individual calls.

    In that case, the problem is on the WebLogic side.  There's probably not much you can do without consulting them.

    Tuesday, February 2, 2016 6:21 PM
    Moderator
  • Hi All,

    Iam posting data to rest service I am getting below error from service.any suggestions

    I am using wcf-custom adapter.

    Well! A quick search on the error "no backend server available for connection timed out after 10 seconds" is not a biztalk error but the error thrown from weblogic.

    It is a bug or configuration issue at weblogic side and you have to go back to the team and inquire about this error.

    "

    It is a known WebLogic bug (CR220685) with the following explanation:

    WebLogic Server no longer retries using a new connection when the following are all true:

    • Idempotent is set to OFF.
    • A recycled connection is being used.
    • The backend server is not responsive.

    The customer needs to contact WebLogic to remedy this problem.

    "

    Show them these blogs:

    http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec499824.aspx

    http://oracletechdba.blogspot.in/2014/10/errorfailure-of-server-apache-bridgeno.html


    Rachit Sikroria (Microsoft Azure MVP)

    • Marked as answer by BizTalk1234 Wednesday, February 3, 2016 5:09 AM
    Tuesday, February 2, 2016 7:08 PM
    Moderator