locked
Azure Resource Manager VM can't connect from Outside RRS feed

  • Question

  • I created a azure vm through resource manager and deployed an application on it. the application works fine when I try to access it from the vm. but when i try it from outside(through internet) it doesn't work. i created an inbound security rule in NSG and opened the port through vm firewall inbound rules too. please give some tips as to why this isn't working
    Saturday, March 26, 2016 8:02 PM

Answers

  • Hi,

    Do you get any error message when you try to connect to your application from outside?
    Also, Would you be able to share the NSG rules you have created so we could check them?
    You could try obtaining a trace route to try and isolate the issue.

    Regards,
    Malar.

    • Marked as answer by lakpriyagk Monday, October 23, 2017 4:41 PM
    Sunday, March 27, 2016 10:24 AM
  • Hi lakpj,
    Thank you for posting here.
    To add to the above, is your application a web application?
    If not, it might be stored in a blob or container and by default have private access means accessed by owner only. That’s may be the reason your application is not accessed by public or internet. Please follow the steps in given link to give the permissions to your application stored in a blob or container to access the public.
    https://azure.microsoft.com/en-us/documentation/articles/storage-manage-access-to-resources/
    Regards,
    Vikranth s
    • Edited by vikranth s Sunday, March 27, 2016 12:39 PM
    • Proposed as answer by Chris GomezMVP Thursday, March 31, 2016 1:31 PM
    • Marked as answer by lakpriyagk Monday, October 23, 2017 4:41 PM
    Sunday, March 27, 2016 12:31 PM
  • Does your VM have a public IP address assigned?

    https://azure.microsoft.com/en-gb/documentation/articles/virtual-network-deploy-static-pip-arm-portal/

    • Marked as answer by lakpriyagk Monday, October 23, 2017 4:41 PM
    Sunday, March 27, 2016 8:02 PM

All replies

  • Hi,

    Do you get any error message when you try to connect to your application from outside?
    Also, Would you be able to share the NSG rules you have created so we could check them?
    You could try obtaining a trace route to try and isolate the issue.

    Regards,
    Malar.

    • Marked as answer by lakpriyagk Monday, October 23, 2017 4:41 PM
    Sunday, March 27, 2016 10:24 AM
  • Hi lakpj,
    Thank you for posting here.
    To add to the above, is your application a web application?
    If not, it might be stored in a blob or container and by default have private access means accessed by owner only. That’s may be the reason your application is not accessed by public or internet. Please follow the steps in given link to give the permissions to your application stored in a blob or container to access the public.
    https://azure.microsoft.com/en-us/documentation/articles/storage-manage-access-to-resources/
    Regards,
    Vikranth s
    • Edited by vikranth s Sunday, March 27, 2016 12:39 PM
    • Proposed as answer by Chris GomezMVP Thursday, March 31, 2016 1:31 PM
    • Marked as answer by lakpriyagk Monday, October 23, 2017 4:41 PM
    Sunday, March 27, 2016 12:31 PM
  • Does your VM have a public IP address assigned?

    https://azure.microsoft.com/en-gb/documentation/articles/virtual-network-deploy-static-pip-arm-portal/

    • Marked as answer by lakpriyagk Monday, October 23, 2017 4:41 PM
    Sunday, March 27, 2016 8:02 PM
  • The issue was solved, sorry for this late response. thank you for your inputs.

    lakpj

    Monday, October 23, 2017 4:41 PM