locked
WinUSB not working on Surface Pro

    Question

  • I have a laptop running Windows 8.1 Pro Preview and VS2013 Premium Preview.  I've written a small Windows Store app to communicate with a USB device using WinUsb (without a custom inf file).  Communication works fine on the laptop. 

    I wanted to test it on a Surface Pro 2 running Windows 8.1 Pro and VS Pro 2013.  The project moved over fine but when I ran the app to communicate with the device, it does not find the device.  It is listed in Device Manager under Universal Serial Bus Devices (just like on the laptop).

    Here is a code snippet:

                        // find all enabled WinUSB devices
                        var selector = "System.Devices.InterfaceClassGuid:=\"" + "{dee824ef-729b-4a0e-9c14-b7117d33a817}" + "\" AND System.Devices.InterfaceEnabled:=System.StructuredQueryType.Boolean#True";
                        var interfaces = await DeviceInformation.FindAllAsync(selector, null);
    
                        foreach (DeviceInformation deviceInterface in interfaces)
                        {
                            // save only XR21v1410
                            if (deviceInterface.Id.Contains("VID_04E2"))
                            { device = await UsbDevice.FromIdAsync(deviceInterface.Id); }
                        }

    I've tried several variations of "selector" and it doesn't seem to make a difference. I have also eliminated "selector" in the FindAlllAsync call to show everything and it still doesn't appear.

    I've tried a custom inf and adding DeviceInterfaceGUID to the registry.

    Any ideas?

    Thanks,


    Cheri


    • Edited by Cheri Reed Friday, December 27, 2013 3:57 PM
    Friday, December 27, 2013 3:44 PM

Answers