locked
ERROR: POCFabricInstaller failed because the following tasks failed: InstallFeature in RunAzureStackDeploymentTask.ps1 L:158 char:19 RRS feed

  • Question

  • We are trying to install AzureStack on the following hardware:

    DELL R900

    192GB RAM

    (4) Quad Processor, 24-Cores Total (6-Core per CPU)

    (5) 300GB SAS Disks

    (1) Dual 10GB Ethernet Adaptor

    We have only 1 network port active, with all others disabled as per instructions in the video.

    We get the following error after we initiate deployment:


    • Edited by Eric2007 Monday, May 9, 2016 4:37 PM
    Monday, May 9, 2016 4:25 PM

All replies

  • Hello Eric,

    Thank you for posting here.

    Could you confirm you are running PowerShell in an admin context?

    Please check the Step-by-Step instructions video demo by Charles on Microsoft Azure Stack POC Deployment Tutorial.

    Regards,

    Pradeep

    Tuesday, May 10, 2016 5:22 AM
  • Hi Pradeep,

    Yes, PowerShell is run in an admin context as it is shown in the image posted in earlier post.

    The URL to the video you have posted is the video I have been following and I am stuck at 23:19 mins into the video.

    Tx

    • Edited by Eric2007 Tuesday, May 10, 2016 4:46 PM
    Tuesday, May 10, 2016 4:43 PM
  • Hi Eric,

    Here is workaround steps to deploy Azure Stack:

    Azure Stack Part one:

    Azure Stack Part two:

    Hope this helps.

    Disclaimer:

    This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.

    Regards,

    Pradeep

    Wednesday, May 11, 2016 7:14 AM
  • Hi,

    The links you have provided don't seem like a work around to me, rather the same thing documented differently.

    The steps however to me, appear the same.

    I went ahead and did a complete fresh re-installation, following the steps in your URL labelled as Azure Stack Part One.

    The only thing I question is the pass-through you speak of on RAID controllers. The only option for pass-through is an alternative terminology on the raid controller listed as "write-through". I have enabled this on all disks and it has made no impact on the outcome.

    I ended up with the same result as before, same error.

    Thus I am still stuck as I am unable to deploy this on a DELL R900.


    • Edited by Eric2007 Friday, May 13, 2016 4:29 PM
    Friday, May 13, 2016 4:28 PM
  • Hi Eric,

    Here are the instructions on the iDRAC pass-through

    "http://en.community.dell.com/techcenter/systems-management/w/wiki/5097.os-to-idrac-pass-through-using-idrac7"

    Regards,

    Pradeep

    Tuesday, May 17, 2016 3:03 AM
  • Hi Eric,

    We have created workspace to upload the log files for analysis. Could you please upload following logs from "$env:ProgramData\Microsoft\AzureStack\Logs"

    You would have received an email with credentials for accessing the workspace.

     

    Regards,

    Pradeep

    Thursday, May 19, 2016 2:56 AM
  • Hi,

    We anticipate that this bug will be fixed in the next TP release.

    As an interim solution, please repave and redeploy Azure Stack.

    Regards,

    Pradeep

    Wednesday, June 1, 2016 3:46 AM
  • Hi,

    I am encountering the same error.

    Tried it four times.

    Hardware :

    Server: HP ProLiant DL580 G5 

    RAM: 256 GB

    CPU: 4 Xeon 7450 hex-core

    RAID Controller : HP SmartArray P400, All five disks(250GB)  are in RAID-0 mode

    Two Gigabit Ethernet NIC's: One is disabled via device manager

    Any additional debugging steps I could follow ?

    Or just wait for the next TP release ?

    Wednesday, June 1, 2016 10:46 PM