IIS php soap webserver works until 40kb RRS feed

  • Question

  • User2030019620 posted

    Hi guys, I have a big problem with a web service soap in php 7.2. everything works very well with requests up to about 40kb. With requests above this dimension, usually with attached PDFs, the request remains pending until the timeout. Of these timeouts I can not find a trace in the failed request trace. In the c: / windows / temp folder I also find all these requests of various sizes, from 40kb to few mb truncated in the last lines of the file. I raised all the possible values ​​in the configuration editor, but I could not solve it

    EDIT: Wrong section, i ve IIS 8.5 and windows server 2012R

    Thursday, February 21, 2019 7:32 PM

All replies

  • User-848649084 posted

    Hi Eis513,

    Increase  value of "Maximum allowed content length" in "Request Filtering" module:

    • Open IIS Manager.
    • Select the website that you want to configure.
    • Select Requests Filtering and open it by double-clicking the icon.
    • From the Actions pane on the right hand side of the screen click Edit Feature Settings.
    • In the Request Limits section, enter the appropriate Maximum allowed content length (Bytes) and then click the OK button.
    • Restart IIS.



    Friday, February 22, 2019 8:32 AM
  • User2030019620 posted

    hi jalpa,

    i've already set this to max possible, but it does't resolve my issue.



    Friday, February 22, 2019 9:52 AM
  • User-848649084 posted


    Did you set  upload_file_size as per your requirement in php.ini file?

    Monday, February 25, 2019 2:05 AM
  • User2030019620 posted

    Hi jalpa, i've tried to make the webserver in asp.net(WCF), same problemfrown

    Monday, February 25, 2019 7:35 AM
  • User-848649084 posted


    Check your code that it has any configuration about it or not?


    Tuesday, February 26, 2019 8:11 AM
  • User2030019620 posted

    nope, my code is very simple, it receive and save a sequence of byte in a file, in a second moment these file will be send to their destinations.....

    Tuesday, February 26, 2019 9:50 AM