locked
VS 2010 find combo box on toolbar problem RRS feed

  • Question

  • Using Visual Studio 2010, when I type in search text in the find combo box on the toolbar, it will not allow me to type in my text, but instead forces case changes that I do not want as it trys to predict what I am typing.  Can this be disabled?  I am forced to disable exact case because I cannot get around this "Feature."
    Wednesday, September 8, 2010 12:35 PM

Answers

  • While installing VS 2010 on my laptop I found the solution to this issue.  Go to "Tools | Options | Environment | Find and Replace" and you will see a check box to "Automatically populate Find What with text from the editor."  Unchecking this box corrected the problem.

    • Marked as answer by Bill Block Wednesday, September 15, 2010 5:11 PM
    Wednesday, September 15, 2010 5:11 PM

All replies

  • Hi Bill,

     

    Thanks for your post.

    I'm afraid VS IDE doesn't provide a setting to disable that kind of intellisense,

    as a workaround, could you please press "Ctrl+Shift+F" to popup the "Find in Files" window, there is no prediction there.

    Hope this can help.

     

    Best Regards,

    Ziwei Chen

     

     

    • Marked as answer by Victor_Chen Monday, September 13, 2010 2:00 AM
    • Unmarked as answer by Bill Block Wednesday, September 15, 2010 5:12 PM
    • Proposed as answer by redtracy Wednesday, December 1, 2010 7:45 PM
    Friday, September 10, 2010 2:25 AM
  • This is a known issue with the Find combobox and is a bug in WPF autocompletion where they replace the entire string instead of appending the text.  The only workaround is to type the second character of the string, press HOME and type in the capital letter.  The fix will be included in the next version of VS. 


    Weston Hutchins | Program Manager | Visual Studio Platform | The Visual Studio Blog
    • Marked as answer by Victor_Chen Wednesday, September 15, 2010 1:33 AM
    • Unmarked as answer by Bill Block Wednesday, September 15, 2010 5:05 PM
    • Proposed as answer by redtracy Wednesday, December 1, 2010 7:47 PM
    Tuesday, September 14, 2010 5:15 PM
  • While installing VS 2010 on my laptop I found the solution to this issue.  Go to "Tools | Options | Environment | Find and Replace" and you will see a check box to "Automatically populate Find What with text from the editor."  Unchecking this box corrected the problem.

    • Marked as answer by Bill Block Wednesday, September 15, 2010 5:11 PM
    Wednesday, September 15, 2010 5:11 PM
  • Bill, I have followed your instructions but it does not work for my VS.  I have restarted the VS a few times after unchecking the box.  I am using VS 2010 Ultimate V10.0.30319.1

    Weston, I assume you mean the next SP by he next version of VS.  I look forward to it.


    hz
    Sunday, January 16, 2011 10:58 PM
  • I couldn't get this to work either - it's clearly unchecked, but the autocompletion insanity is still happening.  Very annoying.  Now I really can't use this box (because I almost always want case-sensitive searches), I have to bring up the bigger search box instead.  I guess I'll rewire myself to use that reasonably quickly.
    Friday, May 13, 2011 4:16 PM