none
Data Sources Troubles RRS feed

  • Question

  • I have a report I'm building that needs to be loaded by xml from another application.  I've created a schema which I then turned into a strongly typed DataSet.  I have tried different approaches to get this to work, but inevitably, I will encounter one of two situations:

     

    1. When changing the properties on the xsd to use the Custom Tool MSDataSetGenerator, the Data Sources pane goes unavailable.  The Data Sources already added disappear.  The tools at the top are disabled.  I am actually able to right click in the empty pane and "Preview Data..." comes up.

     

    2.  If I can put the xsd into another project and change the properties to use MSDataSetGenerator, I'm able to add the datasource via the Data Sources pane.  It will appear below my existing Data Source.  As soon as I click to expand the node, I get the "Microsoft Visual Studio has encountered a problem and needs to close." message box.  I've tried looking at the error report, but it's all memory dumps, etc.

     

    So, I figured I could build the reports and manually add the fields, etc., but my project won't build because the reports don't have DataSets associated with them.  My next hack will be to add the "DummyDataSource" in the xml, but I'd like to do this right. 

     

    Can anyone help me please?  I was supposed to be done with this project like 2 weeks ago.

     

    Thanks,

     

    Brian Lampe

     

     

    Thursday, October 25, 2007 9:22 PM

All replies

  •  

    I've got a sort-of resolution to this problem.  If the DataSet has a table that has two nested relationships, the Data Sources view or pane or whatever it's called will blank out.  The DataSet designer can handle the situation, but the Data Sources thing can't. 

     

    My fix is to flatten out the nested DataTable into the parent nodes since I was only expecting one row per row of the parent tables. 

     

    Seems to me this is a bug as the Data Sources pane is not handling the situation gracefully.

     

    Brian

    Friday, October 26, 2007 10:55 PM