locked
MySql + ASP.NET RRS feed

  • Question

  • User-319370498 posted

    Hi guys,

    I want to program a website with ASP.net and a MySql DB.

    Now I have installed the Mysql Workbench and the MySql connector for .net.

    When I want to make a new connection with a database there is no datasource MySql.

    I'm using the Microsoft Visual Developper 2010 express, is that a problem or have I did something else wrong?

     

    thanks !

    Friday, June 24, 2011 2:22 PM

Answers

  • User-319370498 posted

    I've found the solution.

    I've uninstalled Visual developper 2010 express and MySQL Workbench and the connector.

    Then I installed Visual Studio 2010 proffessional and the workbench and connector.

    And now MySql Database is in the wizardlist.

    Thanks all for helping me finding a solution.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, June 25, 2011 6:29 AM

All replies

  • User1770881099 posted

    Have you added the MySql.Data.dll assembly as a reference to your project?

    Friday, June 24, 2011 2:24 PM
  • User-319370498 posted

    and how should I do that?

    I'm now working with the wizard, my version of Visual Studio has an integrated Databaseview.

    Friday, June 24, 2011 2:36 PM
  • User1770881099 posted

    Right click on the folder named refrences and add a reference. then find the dlll and add it into the project.

     

    Yopu may want to read through this page for some starter steps

     

    http://www.christianasp.net/usingmysql50withaspnet-part1.aspx

    Friday, June 24, 2011 2:40 PM
  • User-319370498 posted

    The dll isn't in te reference list.

    Friday, June 24, 2011 2:48 PM
  • User1770881099 posted

    You have to browse to it.

    Friday, June 24, 2011 2:51 PM
  • User-319370498 posted

    Ok thanks I've found it, but still no MySql datasource in the wizardlist.

    Thanks that you're helping me.

    Friday, June 24, 2011 2:56 PM
  • User1770881099 posted

    Have you walked through this howto?

    http://dev.mysql.com/doc/refman/5.0/en/connector-net-visual-studio-making-a-connection.html

    I believe you have and are not seeing MySQL......

     

    If not, have you restarted visual studio since you installed the mysql connector? If you have I am not sure I will be able to help you anymore since I am unable to install the connector to toy with the settings. You might want to hit up mysql's forum to receive better advice than I am capable of giving.

    Friday, June 24, 2011 3:17 PM
  • User-1166080021 posted

    You only need to create  new database if you don't see the wizard that allow you to choose that only find it in tools.

    when you create the database you can populate tables. stored procedures, etc, and then you can export that database.

    But i think VS 2008 or 2010 have MySql so only need to find it.

    tell me if you can fix your problem, I'll help you if not!

    good Luck!

    Friday, June 24, 2011 10:09 PM
  • User-319370498 posted

    I've found the solution.

    I've uninstalled Visual developper 2010 express and MySQL Workbench and the connector.

    Then I installed Visual Studio 2010 proffessional and the workbench and connector.

    And now MySql Database is in the wizardlist.

    Thanks all for helping me finding a solution.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, June 25, 2011 6:29 AM
  • User-1166080021 posted

    I'm glad that you resolve your problem!

    please mark as answer if something here help you!

    Good Luck!

    Saturday, June 25, 2011 9:01 AM