none
Not able to format NAND boot section partition RRS feed

  • Question

  • Hi All,

     

    I am working with OMAP35xx and wince6, 8 bit NAND (micron)

    We want to format OS partition. We have first 15 blocks reserved for xloder and eboot. Then 380 blocks for OS.

    This 380 blocks needs to be formated. Without erasing MBR block i tried to format the OS blocks.

    Erase is happening then NK is flashed and booted from NAND successfully. If we repeat the same OS format and NK flash its not booting st rucking at the wince image launch every second time.

    We are using hive based registry.

     

    After displaying the below message it strucks :-

    ******************************************************************

    Launch Windows CE image by jumping to 0x80001000...

    Windows CE Kernel for ARM (Thumb Enabled) Built on Oct 20 2009 at 18:39:19
    --- High Performance Frequecy is 32768 khz---
    media contains 1 flash regions:
        Type=2, StartP=0x0, NumP=0x1000, NumL=0x0, Sec/Blk=0x40, B/Blk=0x20000, Comp
    act=4.
    media contains 0 reserved regions:

    ****************************************************************

     

    Please share your thoughts

     

    Regards,

    Misbah

     

    Wednesday, February 2, 2011 6:36 AM

All replies

  • Which Flash Driver do you use?
    MSFlash MDD/PDD or FMD/FAL?
    And how do you configure your root storage, Internal ObjectStore or Flash?

    Wednesday, February 2, 2011 8:48 PM
  • We are using FMD flash driver.

    root storage is Flash.

     

    regards,

    Misbah

    Friday, February 4, 2011 5:33 AM
  • In your boot loader, do you also creat an MBR compatible partition for your storage?
    If not, as the File System can not mount the root valume, so the hanged is expected.

    Monday, February 7, 2011 10:34 PM
  • Hi KMOS,

    During NAND boot, in OEMPreDownload() NK image is read from the partition. This happens only when the partition is available(i.e., MBR sector exists with valid data).

    After this image read, when the system tries to launch the image, then its not fully coming up.

    This happens only for the second reset or the second time Nand OS partition format.

     

    Regards,

    Misbah

    Tuesday, February 8, 2011 9:48 AM
  • I have a feeling it might be all about the hive based registry issue.
    HAve you tried to unset the IMGREGHIVE in your TI_EVM_3530.BAT and then rebuild the platform to narrow down if that is the root cause?
    Tuesday, February 8, 2011 7:54 PM
  • Yes KMOS the issue is with the hive.

     

    I changed the registry from Hive to RAM  it works. But how to solve this issue because we need hive registry.

     

    Can you give some suggestion.

     

    regards,

    Misbah

    Wednesday, February 9, 2011 8:59 AM
  • You need to make sure your NAND filesystem is available in the first bootphase.  That means it needs to be correctly configured in the registry, and all the registry settings involved need to be wrapped with HIVE BOOT SECTION tags.
    Dean Ramsier eMVP BSQUARE Corporation
    Wednesday, February 9, 2011 2:34 PM
  • Hi Dean,

    How to make sure that NAND filesystem is available in first bootphase. What registry settings are required ?

    If you can give some clue or reference it would be helpful.

     

    Regards,

    Misbah

    Thursday, February 10, 2011 5:44 AM
  • As Dean said ,the registry settings related to NAND Flash should be inside the following tags
     
    ; HIVE BOOT SECTION
    <NAND Flash Registry Settings>
    ; END HIVE BOOT SECTION
     
    Check out the 4th point in the following link.
    Thursday, February 10, 2011 6:23 AM
  • Hi Prabu,

    Thanks for the reply!

     

    I checked and all the registry settings for the NAND is under "HIVE BOOT SECTION" and " END HIVE BOOT SECTION"


    I think may be some flag is not set properly or some configuration in registry is making NAND filesystem not available in first bootphase.

     

    By the way the link provided by you is of the same post. Can you please give the appropriate link to refer 4th point.

     

    Regards,

    Misbah 

     


    Thursday, February 10, 2011 6:47 AM
  • I am suspecting that the area used for NAND Flash file system is not formatted. Did you format  the NAND Flash used for filesytem in eboot?
    Vinoth.R http://vinoth-vinothblog.blogspot.com http://www.e-consystems.com
    Thursday, February 10, 2011 7:38 AM
  • Hi Vinoth,

    I have a driver to format only the blocks which are partitioned under

    BOOTSECTION(this doesnt include any other blocks like xloader,eboot(reserved in this case)

    and the DOS32(other partition))

     

    using our driver we are formatting only kernel blocks (~374) and reflashing the NK image via bootloader API also via kernel level API

     

    Regards,

    Misbah

    Thursday, February 10, 2011 9:22 AM