locked
Windows 10, IIS 10, Visual Studio 2017 setup RRS feed

  • Question

  • User-608909308 posted

    I have a fresh install of Windows 10 Pro and just installed Visual Studio 2017 Community Edition.

    I created a web project, and configured it to use http and IIS on the localhost. The project runs fine if I view it from a browser.  But I cannot run debug (even running as administrator) or I get an error of :

    "Unable to start debugging on the web server. The remote server returned an error:(404) Not Found."

    I tried to use IIS Manager to figure out what is happening.  When I look at the basic setting of the default website and then click test settings I see two test results:

    Authentication: Passed

    Authorization: Cannot verify access to path.

    So following the advice of the https://stackoverflow.com/questions/14653722/how-do-i-give-asp-net-permission-to-write-to-a-folder-in-windows-7  I gave the application pool identity access to C:\inetpub\wwwroot.  That did not help.  I gave everyone full control of c:\inetpub\wwwroot.  Still no change.

    I looked in event viewer on my machine and I do not see any audit failures so I can't tell if security permissions are the problem or not.

    Any suggestions or references?

     

    Saturday, August 19, 2017 12:45 PM

Answers

  • User1771544211 posted

    Hi jmal327,

    I created a web project, and configured it to use http and IIS on the localhost. The project runs fine if I view it from a browser.  But I cannot run debug (even running as administrator) or I get an error of :

    Could you please share the following information here?

    1. Which url do you use to access the website from a browser?
    2. Which url do you set as the Project Url in VS when you use Local IIS as web server?
    3. Is there any detailed error message about the 404 error?

    Authorization: Cannot verify access to path.

    Since the error is 404, it shouldn't related to permission issues. If you want to fix this, you can create an admin account on the server, then in the Basic Settings -> Contact As set the admin account as the path credential.

    Best Regards,

    Jean

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, August 21, 2017 2:38 AM

All replies

  • User1771544211 posted

    Hi jmal327,

    I created a web project, and configured it to use http and IIS on the localhost. The project runs fine if I view it from a browser.  But I cannot run debug (even running as administrator) or I get an error of :

    Could you please share the following information here?

    1. Which url do you use to access the website from a browser?
    2. Which url do you set as the Project Url in VS when you use Local IIS as web server?
    3. Is there any detailed error message about the 404 error?

    Authorization: Cannot verify access to path.

    Since the error is 404, it shouldn't related to permission issues. If you want to fix this, you can create an admin account on the server, then in the Basic Settings -> Contact As set the admin account as the path credential.

    Best Regards,

    Jean

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, August 21, 2017 2:38 AM
  • User-608909308 posted

    Thanks Jean.  You are correct, the problem was not security.  The problem was I installed IIS after installing the .NET Framework.  So .NET never got properly registered with IIS10.  

    Used to be we would run aspnet_regiis in previous version of Windows.

    But in Windows 10 the command is:

    dism /online /enable-feature /all /featurename:IIS-ASPNET45

    I found the answer at http://www.jammer.biz/enable-asp-net-on-windows-10/

    Wednesday, August 23, 2017 12:34 AM