none
January update broke debug kernel builds for ARMV7 RRS feed

  • Question

  • Hello,

    I am having issues running debug build of my kernel for iMX6, release build runs fine.

    They simple don't start.

    Not sure how but it started happening after January update installed.

    I tried rolling back my WINCE700 tree and after I reverted it to pre-january update problem was resolved.

    Here is how it look:

    Bootloader starts normally, boots kernel from SD card and tries launching it.

    Launch never succeeds, no kernel debug log messages see on serial line.

    The last message is from bootloader: launching

    I attempted to run Trace32 JTAG debugger to investigate where it hangs.

    Unfortunately even JTAG debugger failes to connect to my board saying 'bus error generated by CPU'

    It look like that CPU is in the unrecoverable state...

    Has anyone experienced the same issue?

    Any suggestion of how to fix/investigate it would be really appreciated.

    Thanks,

    Alexey

    Tuesday, March 15, 2016 11:28 AM

All replies

  • Hi Alexey,

    I have raised this post to the Sustained Engineering team for review.  What BSP are you using? Is there anything unique about your setup?

    Sincerely,

    IoTGirl

    Tuesday, March 15, 2016 5:33 PM
    Moderator
  • Hi,

    Thank you very much for your reply.

    There is nothing very unique about my setup: board is Freescale Sabre SDP based with some hardware differences.

    I am using iMX6 BSP made by guruCE.

    Unfortunately they are not able to reproduce them so this is hardly a OS tree issue.

    Except of course my personal installation problem.

    My current plan is to run full repair for PB and OS tree and see whether it fixes the issue or not.

    Thanks for your time.

    Alexey

    Wednesday, March 16, 2016 8:33 AM
  • Thank you for the follow up Alexey and please update the forum when you find a solution.
    Wednesday, March 16, 2016 5:08 PM
    Moderator