none
Kinect2 Flashes on and off RRS feed

  • Question

  • I have my Kinect 2 for Windows connected to a Dell T5610 with a Quadro K4000 and Windows 8.1 Enterprise.  The USB configuration looks like included image.

    When the Kinect2 is running the highlighted area turns off, restarts, then turns off again.  The result is that Kinect2 works for a second, turns off for 15 seconds, then starts and runs for a second again.

    Is there a problem with my configuration?  Do others have the same problem?

    Thank you,

    Anthony

    Monday, November 17, 2014 1:22 PM

All replies

  • I would think there appears to be an issue with your USB host controller/port. It could be it's not getting enough power. Have you run the configuration verifier, and looked at the following threads to verify you don't have any offending components:

    https://social.msdn.microsoft.com/Forums/en-US/20dbadae-dcee-406a-b66f-a182d76cea3b/troubleshooting-and-common-issues-guide?forum=kinectv2sdk

    https://social.msdn.microsoft.com/Forums/en-US/bb379e8b-4258-40d6-92e4-56dd95d7b0bb/confirmed-list-of-usb-30-pcie-cardslaptopsconfigurations-which-work-for-kinect-v2-during?forum=kinectv2sdk

    Also try using a powered USB hub. It could help.


    Sr. Enterprise Architect | Trainer | Consultant | MCT | MCSD | MCPD | SharePoint TS | MS Virtual TS |Windows 8 App Store Developer | Linux Gentoo Geek | Raspberry Pi Owner | Micro .Net Developer | Kinect For Windows Device Developer |blog: http://dgoins.wordpress.com

    Monday, November 17, 2014 5:53 PM
  • I have added an addition troubleshooting steps to assist with the restarting issue to the guide. Please try those out.

    Carmine Sirignano - MSFT

    Monday, November 17, 2014 7:04 PM
  • I tried out the recommended "pluggable" USB adapter.  That also did not work.

    I also switched out the device for another and that didn't work either.

    I have seemed to go through the check list to get everything but no luck.  The only thing that I failed to check was the BIOS but I am 500 miles from the computer now and can't check that.

    Any additional suggestions would be great! 

    Anthony

    Edit:  My USB BIOS settings are:

    Category Name : USB Settings
    Setting    Value
    internalusb    on
    usbemu    enable
    usbportsfront    enable
    usbrearquad    on
    usbwake    disable

    And my power and performance are:

    Category Name : Power and Performance Management
    Setting    Value
    acpower    on
    advbatterychargecfg    disable
    autoon    disable
    autoonhr    0
    autoonmn    0
    blocks3    disable
    cpucore    all
    cstatesctrl    enable
    deepsleepctrl    disable
    fanctrlovrd    disable
    fanspeed    auto
    hwprefetcher    enable
    logicproc    enable
    peakshiftcfg    disable
    speedstep    automatic
    turbomode    enable
    uefinwstack    disable
    wakeonlan    enable

    Sunday, November 23, 2014 6:50 PM
  • If you are 500 miles how are you testing this? Did you not see the known issues for Remote Desktop, which is also mentioned in the last steps?

    http://msdn.microsoft.com/en-us/library/dn758677.aspx

    Remote Desktop

    •         If you are accessing the Kinect using Remote Desktop, You must change the remote desktop audio settings to "play on remote machine".         If you do not do this, the runtime will not be able to see the audio device, and may disallow connection to the Kinect.      


    Carmine Sirignano - MSFT

    Monday, November 24, 2014 6:48 PM