none
How do I modify my settings to allow VS2010 to load 3rd party XSD files from the “Unauthorized Zone”? RRS feed

  • Question

  • I have opened a 3rd party XSD file in Visual Studio 2010 that imports namespaces from other schema files from the same 3rd party.

    In the XML editor view of the schema file, the xs:import element is underlined with the following error: Request for the permission of type 'System.Security.Permissions.FileIOPermission', mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

    I read the following blog post: http://blogs.msdn.com/b/xmlteam/archive/2009/06/04/understanding-xml-schema-sets-in-the-xsd-designer.aspx which states that it's a security zone violation and Visual Studio places the schemas in the "Unauthorized zone" in the XML Schema Explorer.

    My question is - how do I change my security settings to allow these schemas to be referenced, or is there something I can do to make the schemas and namespaces associated with them "trusted"?

    • Moved by Brittany Behrens Tuesday, July 6, 2010 6:35 PM XML Editor team should respond to this question. (From:Visual Studio Editor)
    Friday, July 2, 2010 3:56 PM

Answers

All replies

  • Hello Mike,

     

    Welcome to MSDN forums!

     

    I think this thread can help you, http://stackoverflow.com/questions/2919470/what-does-unatuthorized-zone-mean-when-browsing-xsd-files-with-visual-studio-20.  

    "You should check your networking options so you may download those xsd files.While you can it means you have access to that location,so Visual Studio can cache them.If you're sure that you have access,you may also download those xsd files and put them Visual Studio's default schema location and indeed add them in editor.”

    Good day!

    Best Regards,
    Lingzhi Sun

    MSDN Subscriber Support in Forum

    If you have any feedback on our support, please contact msdnmg@microsoft.com


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Thursday, July 8, 2010 2:26 AM
    Moderator
  • Another possible problem is that the schemas are be in a blocked state. 

    If you downloaded your schema's from the web they may be being blocked by the OS. 

    In an Explorer window navigate to your schemas. Right click on the schema and select properties.  If you see a button at the bottom of this window that says unblocked it could be possible the OS is blocking this schema.  Click this button to unblock the schema.  

    If you had your project open in Visual Studio you will need to close and reopen it.

    This solved my problem,

     




    • Proposed as answer by SkiGeek Tuesday, May 17, 2011 6:44 PM
    Tuesday, May 17, 2011 6:42 PM
  • I am sorry but none of mentioned solutions helped me. I have this schema http://www.loc.gov/standards/alto/alto-v2.0.xsd.

    I have set location of imported schema to thrusted zone(In Control panels). No effect.

    I have put imported xsd to VS cache. No effect.

    Is there anythink else, what I can do to make it work?

    I think this is serious limitation of VS. There are lots of xsd with import tags.

     

    Would not be easier to mark xsd as thrusworthy in VS IDE?

     

    Wednesday, August 10, 2011 10:30 AM
  • Wow. This turned out to be my issue. The XSD files were in a "blocked" state because they were downloaded from the Internet at some point. Thank you!
    Wednesday, February 27, 2013 7:29 PM