none
Visual studio has stopped working

    Question

  • Hello,

    Whenever I start Visual studio 2015 Enterprise,I am getting the error "Microsoft.VsHub.Server.HttpHostx64.exe has stopped working".I tried https://thomas-barthelemy.github.io/2015/05/01/visual-studio-vshub/ link but still getting the same error.And it is weird that I can run my solution perfectly but only the issue is I am getting the same error after each 5-10 seconds. 

    Thursday, March 2, 2017 4:40 AM

All replies

  • Hi zula Jariwala,

    Welcome to the MSDN forum.

    Refer to the error message “Microsoft.VsHub.Server.HttpHostx64.exe has stopped working”, I found some workarounds as below:

    1. What’s your antivirus software? There are a couple of known incompatibilities that might be causing this as below, for the detail information, please check this: HttpHostx64.exe has stopped working
    -    Astrill (check for ASProxy* in the system directory): Workaround is to either add HttpHost to an exclude list in Astrill (see workaround in this Connect item) or remove it
    -    LavaSoft (check for LavasoftTcpService* in the system directory): Only known workaround is to remove it, uninstalling Webcompanion by Lavasoft works for some other community members

    2. Go to the path: C:\Program Files (x86)\Common Files\Microsoft Shared and rename the folder VsHub to others

    3. Make sure VS is close and VSHub is not running in Task Manager, install this update: Update to improve Diagnostic Tools in Visual Studio 2015

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 3, 2017 3:03 AM
    Moderator