locked
"Setup could not install .... Expression Blend 4 for Windows Phone" RRS feed

  • Question

  • Hello,

    I installed the Windows Phone Developer Tools Beta 1.0. After the install process I get the following message:

    "Setup could not install the following component:

    Expression Blend 4 for Windows Phone"

    I installed the tools on Windows Vista x64 (german). Expression Studio 4 Ultimate (german) is installed. Expression Blend 4 RC was installed but has been uninstalled before installing Expression Studio 4 Ultimate.

    Unfortunately I could not find any help on this. There is an article about some known issues where I found the hint to reboot the system and try to install Expression Blend 4 for Windows Phone again. I did this but it didn't solve the problem. Install of Expression Blend 4 for Windows Phone failed again.

    Visual Studio Express 2010 for Windows Phone installed succesfully and I can build Phone apps and run them in the emulator.

    How do I solve this? Any help would be very welcome!

    Best regards,

    Martin

     

    Saturday, July 24, 2010 12:26 PM

All replies

  • Hi Martin,

    Can you please try this?

    Restart your comptuer (this is most likely why Expression Blend failed to installed - we block when you have a pending reboot required)
    Re-run the Windows Phone Developer Tools installers - you will most likely get a chance to fix the installation

    Does that work?

    Thanks,

    Unni


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Saturday, July 24, 2010 6:25 PM
  • Hi Unni,

    I did that like it was suggested in the blog post I mentioned. Unfortunately it doesn't fix the problem.

    Sunday, July 25, 2010 4:07 PM
  • The only other option I can think of is to try to uninstall and reinstall the Windows Phone Developer Tools. Our sincere apologies for this inconvenience - we are hoping to have this resolved for the next release.

    Thanks,
    Unni


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Sunday, July 25, 2010 8:34 PM
  • Thanks Unni Ravindranathan, your suggestion worked for me. I was postponing the updates while I was installing the tool. Later after restart, I install the component and it worked.

     

    Raman Shakya

    • Proposed as answer by ozkarLeo Monday, May 16, 2011 7:40 PM
    • Unproposed as answer by ozkarLeo Monday, May 16, 2011 7:40 PM
    Wednesday, August 4, 2010 5:34 AM
  • Hi Unni

    Same problem *1) on "all" my computers (win 7 prof, ultim, 64).
    Nothing helped (restart, reinstall, dowbload an run as administrator... aso).

    Solution
    1. Uninstall "Microsoft Expression Blend 3 (with Sketch Flow)" German > Installation failed again
    2. Uninstall "Microsoft Expression Blend 3 SDK" > Installation worked (without a restart)
    (>perhaps it's enough to uninstall the SDK, perhaps a change in the registry would also help)

    Remark
    In the past, I (really) lost many hours to resolve installation-problems/conflicts like this (SQL, Components, final Version after Beta, etcetcetc...),
    please... my opinion:
    -if a further component is needed to (un)install a software/component (ask and) (un)install it!
    -languages ((location)) are "simple text" > please get it "out of a program" and don't interwave it with the functionality
    -an installation failure because of a registry-entry (from a (Beta) program) is mostly not a good idea
    -if it's too complex to test/control all system-configurations and registry-entries (from xyz-software) look for a better/simpler solution 

    greetz & thx, Nick

    *1) Error-Log:
    [08/15/10,17:19:28] Expression Blend 4 for Windows Phone: C:\Users\...\AppData\Local\Temp\30319.105\1033\VM_EXP\wcu\windowsphone\Blend_Trial_en.exe exited with return value 2147943706
    [08/15/10,17:19:28] Expression Blend 4 for Windows Phone: CreateProcess internal result - if available:
    [08/15/10,17:19:28] InstallReturnValue: GFN_MID Blend Trial, 0x8007051a
    [08/15/10,17:19:28] Setup.exe: AddGlobalCustomProperty
    [08/15/10,17:19:29] Expression Blend 4 for Windows Phone: ***ERRORLOG EVENT*** : Error code -2147023590 for this component means "Dies zeigt an, dass zwei Revisionsstufen nicht kompatibel sind.
    ...
    [08/15/10,17:19:32] SimpleUI: ISetupManager::GetGlobalCustomProperty() failed to find global prop in CProgressPage::RunningComponent()

    *2) ex. after installing Ultimate RC it is/was not possible to install Win Prof /> a manual change of a "stupid" registry entry resolved the problem...

    Sunday, August 15, 2010 4:32 PM
  • One more thing you can check when you see Blend installation failure is to check %TEMP%\dd_Blend_Install.txt file. We saw this kind of error:
    Microsoft Expression Blend 3 SDK 1.0.1343.0 cannot be installed until the following conflicting programs have been removed by the user: Microsoft Expression Blend 3 SDK (1.0.1343.0).

    This makes it easy to find out what's blocking the setup.

    Thanks

    Xu

    Monday, September 27, 2010 6:16 AM
  • I have the same problem when trying to install the Microsoft Expression Blend 4 for seven phone windows tells me "Could not install the setup Following components. " How do I fix it?
    Friday, April 22, 2011 3:37 PM
  • I have the same problem when trying to install the Microsoft Expression Blend 4 for seven phone windows tells me "Could not install the setup Following components. " How do I fix it?
    Friday, April 22, 2011 3:37 PM
  • I have the same problem when trying to install the Microsoft Expression Blend 4 for seven phone windows tells me "Could not install the setup Following components. " How do I fix it?
    Friday, April 22, 2011 3:37 PM
  • Reboot/uninstall/search for left blend in regedit : all of these did not work

    The initial message in WinPhoneSDK installation is not informative enough. What you should do is :

    - download an ISO file for the windows phone sdk
    - use something like daemon tools to browse the iso and open the Blend_WindowsPhone installer exe

    A more explicit error may appear : in my case it was something like "could not find TEMP env variable". After fixing the env var, it finally went ok.

    Dear MS, please, hire me or post reward, or pay more attention to what NickNackNick suggested. BR.

    [10/26/12,17:34:31] Microsoft Expression Blend 4 pour Windows Phone 7.1: f:\.\wcu\windowsphone\Blend_WindowsPhone_fr.exe exited with return value 2147942603
    [10/26/12,17:34:31] Microsoft Expression Blend 4 pour Windows Phone 7.1: CreateProcess internal result - if available:
    [10/26/12,17:34:31] InstallReturnValue: GFN_MID Blend Trial 7.1, 0x800700cb
    [10/26/12,17:34:31] Setup.exe: AddGlobalCustomProperty
    [10/26/12,17:34:31] Microsoft Expression Blend 4 pour Windows Phone 7.1: ***ERRORLOG EVENT*** : Error code -2147024693 for this component means "The system could not find the environment option that was entered.
    "
    [10/26/12,17:34:31] Setup.exe: AddGlobalCustomProperty
    [10/26/12,17:34:31] Microsoft Expression Blend 4 pour Windows Phone 7.1: ***ERRORLOG EVENT*** : Component Microsoft Expression Blend 4 pour Windows Phone 7.1 returned an unexpected value.
    [10/26/12,17:34:31] Setup.exe: AddGlobalCustomProperty
    [10/26/12,17:34:31] Microsoft Expression Blend 4 pour Windows Phone 7.1: ***ERRORLOG EVENT*** : Return from system messaging: The system could not find the environment option that was entered.

    • Proposed as answer by mlo77 Friday, October 26, 2012 4:00 PM
    Friday, October 26, 2012 4:00 PM