locked
VS2008-VSS 2005 on Vista - Prompt For exclusive checkout RRS feed

  • General discussion

  • Hi

        I've experimented a little problem in the subject configuration.
        In the default Visual Studio - Visual SourceSafe environment configuration, starting from Visual Studio 2005, when you try to edit a file which is not checked out, automatically this file will be checked out from source safe and you can start to edit it, without any information on this (like a prompt) from the environment.
        I usually prefer to customize this kind of Visual studio - Visual SourceSafe integration environment, in order to be prompted from the environment (with a dialog box) when I'm trying to edit a file which is not "checked out".
        This helps me to keep maximum control of what are the files that I've checked out (in a multi-user environment, this helps a lot, because a check-out implies that other users cannot edit this file).
         In the environment mentioned in the subject, that is:
                - VS 2008
                - VSS 2005
                - Vista Business (Italian edition)
         even if I put the customized option to obtain the prompt, that is, on the VS 2008 development environment:
                 Tools - Options - source Control - Environment - Checked in item behaviour:
                           On Save: Prompt for checkout
                           On edit: prompt for exclusive checkout
         I can't obtain what I expected.

         Can someone help me for this?

    Andrea Lazzarini
          
         
    andrea lazzarini
    • Changed type Feng Chen Tuesday, August 12, 2008 4:02 AM Need feedback.
    Thursday, August 7, 2008 8:24 AM

All replies

  • Could you please first apply the SourceSafe 2005 Update and try again?

    Thanks!

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Friday, August 8, 2008 2:25 AM
  • We are changing the issue type to “General Discussion” because you have not followed up with the necessary information. If you have more time to look at the issue and provide more information, please feel free to change the issue type back to “Question” by editing your initial post and changing the radio button at the top of the post editor window. If the issue is resolved, we will appreciate it if you can share the solution so that the answer can be found and used by other community members having similar questions. 

    Thank you! 

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Tuesday, August 12, 2008 4:03 AM
  • in VS2008
    Options>Source Control> Environment>
    Under "Checked in item behaviour"
    change "on Edit" selected list to "Prompt for checkout"

    Hope it will solve the prb.
    Thursday, February 18, 2010 11:44 AM