none
Could not load file or assembly ‘Oracle.DataAccess' while generating Schema for Oracle View RRS feed

  • Question

  • Hi Friends,

    To enable BizTalk Adapter Pack to get connected to Oracle I the pre-requisites to install Oracle Client on BizTalk Machine.

    This is very well defined in Sandro's and Steef's blogs.

    https://blog.sandro-pereira.com/2017/10/05/biztalk-server-2016-could-not-load-file-or-assembly-oracle-dataaccess-version-or-one-of-its-dependencies/

    https://blog.steef-jan-wiggers.com/2011/04/table-operation-on-oracle-11g-xe-with-oracledbbinding/

    But My Problem is that even after installing the Oracle Clients(tried 11g and 12c 32 bit as well as 64 bit) on my BizTalk Server(on Azure), though I am getting Success Confirmation that product is installed, looks like it is not being installed. It is evident from:

    1. DLL not visible in GAC

    2. Oracle CLient not visible in Programs not even on control panel

    3. On Clicking the Set up again , it is not giving option to modify or uninstall.

    My Environment:  Windows 2016, BizTalk 2016

    When I am trying to generate schema , it is throwing error:

    Connecting to the LOB system has failed. 
    Could not load file or assembly 'Oracle.DataAccess, Version=4.121.1.0, Culture=neutral, PublicKeyToken=89b483f429c47342' or one of its dependencies. The system cannot find the file specified..

    Any pointers would be highly Appreciated.

    Regards,

    vikingsss

    Friday, November 17, 2017 1:01 PM

All replies

  • Hi,

    Have you verified your GAC ? Is the Oracle assemblies present  in the location.

     
    C:\Windows\Microsoft.NET\assembly\GAC_64\Oracle.DataAccess\v4.0_4.121.1.0__89b483f429c47342\oracle.dataaccess.dll
    C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Oracle.ManagedDataAccess\v4.0_4.121.1.0__89b483f429c47342\oracle.manageddataaccess.dll

    If not you have not installed the oracle client properly or might be wrong version, 


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply

    Friday, November 17, 2017 1:46 PM
  • No Abhishek, As I had stated earlier Dll's are not present in GAC. Also I am not sure how to install a client properly as it is a .exe set up file and we need to just click NEXT button and after clicking FINISH it shows the message client has successfully installed. Now incorrect version, I have tried both available versions 12c and 11g both 32 and 64 but with no luck.

    Regards,

    Vikingsss

    P.S - If someone has 10g client, please provide me, I want to try with that version also, this client executable is no more available from OTN.


    • Edited by vikingss Saturday, November 18, 2017 3:33 AM
    Saturday, November 18, 2017 3:31 AM