none
Subject Field coming as UTF 8 msg when using SMTP Dynamic Send port RRS feed

  • Question

  • Hello All,

     

    I have created a BizTalk project which sends the email using dynamic send port with the help of SMTP Adapter. This project is not having the Orchestration. Location and Adapter to be used are also being notified dynamically. It is achieved by the receive pipeline component by promoting OutboundTransportType and OutboundTransportLocation. In dynamic send port, it is achieved by Filters with the properties BTS.OutboundTransportType, BTS.OutboundTransportLocation and BTS.ReceivePortName.

     

    I selected the adapter as SMTP and sending the Email to the recipent address with a Subject Message. For SMTP adapter, am promoting the FROM, To and Subject Fields as SMTP properties in the same receive pipeline(C# code). I am able to get the email and the fields From and To are displaying correctly but the subject field is being displayed as UTF 8 encoding text.

     

    For example, if the Subject field present in the input instance contains "ABC", subject field is coming as "?utf-8?B?YWEQ==" in the email. That is Base64 conversion of the original message. Could you help me in resolving this issue.

     

    Many Thanks in advance

    Tuesday, January 18, 2011 5:11 PM

All replies

  • Were you able to solve this issue becuase i have the same issue here, and the customers i send the mail to require a plain Subject ....

     


    Well0549, Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread
    Tuesday, April 26, 2011 1:23 PM