locked
Sharepoint Document not showing version history RRS feed

  • Question

  • Hello All,
    I have sharepoint Document library with versioning turned on. When i open a SharePoint word document in word 2007, under review tab I could see version history and i can compare both minor and major version of the very same document. All of a sudden it stopped showing the list of versions available for comparison...it shows the dialog to pick documents to compare with as if the opened document is a locally stored. I do not see the available versions for that documet at all. But i can see the history of version in sharepoint site itself. the problem is when a user wants to comapre the content of a document between versions, we are forced to use office and it supposed to work(it was working...nothing changed other than number of document and versions in that library).

    it works for only one user and only on his pc.... and initially i thought its a office isntall issue...but i ahve development SP site with the same set up. if i pull a document on my machine from this dev SP site, it shows all the avaliable version for comparison.

    Could someone shed some light on this please.

    Thanks,
    P.Raaj
    • Moved by Mike Walsh FIN Friday, February 26, 2010 2:02 PM admin q (From:SharePoint - General Question and Answers and Discussion (pre-SharePoint 2010))
    Friday, February 26, 2010 1:42 PM

Answers

  • If you login Windows with some user who does not have the View Versions List Permission, you will get access denied error message when you try to compare document versions in Word, since Word default runs in the security context of current Windows session. In web browser, you may sign in with another user who has the View Versions permission, so, you can see the version history list.

     

    Also, in document library settings->versioning settings, please check the draft item security, maybe the user does not have permission to view draft items.

    • Marked as answer by GuYuming Saturday, March 6, 2010 4:28 AM
    Tuesday, March 2, 2010 5:51 AM