none
Invalid provider type specified RRS feed

  • Question

  • I'm trying to connect to a web service using a certificate, but am getting the error "Invalid provider type specified".  I'm using VS 2012 and .NET 4 framework.  Below is my config info:

    <system.serviceModel>
        <bindings>
          <wsHttpBinding>
            <binding name="Binding1" textEncoding="utf-8" messageEncoding="Text">
              <security mode="TransportWithMessageCredential">
                <transport clientCredentialType="None" proxyCredentialType="None"/>
                <message clientCredentialType="Certificate" negotiateServiceCredential="false" establishSecurityContext="false"/>
              </security>
            </binding>
          </wsHttpBinding>
        </bindings>
        <client>
          <endpoint address="https://myservice" binding="wsHttpBinding" bindingConfiguration="Binding1" contract="CMMServiceReference.CMMData" name="WSHttpBinding_Binding1" behaviorConfiguration="Binding1Behavior"></endpoint>
        </client>
        <behaviors>
          <endpointBehaviors>
            <behavior name="Binding1Behavior">
              <clientCredentials>
                <clientCertificate x509FindType="FindBySerialNumber" findValue="12345"/>
                <serviceCertificate>
                  <authentication certificateValidationMode="None"/>
                  <defaultCertificate x509FindType="FindBySerialNumber" findValue="12345"/>
                </serviceCertificate>
              </clientCredentials>
            </behavior>
          </endpointBehaviors>
        </behaviors>
      </system.serviceModel>

    Tuesday, March 12, 2013 3:15 PM

Answers