none
browse sample (HTML Viewer control) from 6.5.3 DTK doesnt work on actual device with build 23569

    Question

  • the "Windows Mobile 6.5.3 DTK\Samples\PocketPC\CPP\win32\browse" doesn't show web content on devices with rom builds 6.5.3/6.5.5 like latest build 23569.

    some points:

    * the sample works on the 6.5.3 emulator

    * the sample works on devices with 6.5.0 builds like 21908

    * PIEHTML window is created, and no errors on code at all, just blank screen

    * seems like it is possible to make PIEHTML work on 6.5.5 because it is used successfully on Market Place application

    ...so if any one managed to use PIEHTML on those builds with the custom roms, please share your piece of code

    thanks

    Sunday, July 11, 2010 2:28 PM

Answers

  • As this issue is specific to a build, you may need to contact the OEM or Microsoft Technical Support. An alternative is to use IWebBrowser2 interface instead. See the MiniPIE sample in the folder "SDK\Samples\Common\CPP\ATL\MiniPIE".


    Please mark the post that helps you, and unmark that does not. This benefits our community.

    this issue regard most of the 6.5.3 / 6.5.5 builds i have come around.

    the MiniPIE sample ends up the with the same results, a blank PIEHTML window.

    a work around for this problem is to replace the webview.dll as suggested here: http://forum.xda-developers.com/showthread.php?t=624465

    Thursday, July 15, 2010 5:25 AM

All replies

  • As this issue is specific to a build, you may need to contact the OEM or Microsoft Technical Support. An alternative is to use IWebBrowser2 interface instead. See the MiniPIE sample in the folder "SDK\Samples\Common\CPP\ATL\MiniPIE".


    Please mark the post that helps you, and unmark that does not. This benefits our community.
    Wednesday, July 14, 2010 7:15 AM
    Moderator
  • As this issue is specific to a build, you may need to contact the OEM or Microsoft Technical Support. An alternative is to use IWebBrowser2 interface instead. See the MiniPIE sample in the folder "SDK\Samples\Common\CPP\ATL\MiniPIE".


    Please mark the post that helps you, and unmark that does not. This benefits our community.

    this issue regard most of the 6.5.3 / 6.5.5 builds i have come around.

    the MiniPIE sample ends up the with the same results, a blank PIEHTML window.

    a work around for this problem is to replace the webview.dll as suggested here: http://forum.xda-developers.com/showthread.php?t=624465

    Thursday, July 15, 2010 5:25 AM