none
2010 Exchange Managed Folder properties RRS feed

  • Question

  • Moved thread here per previous thread:

    http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/f4fca678-a03d-407d-b18c-70ed759fcd9c

     

    So I have 2 Exchange 2010 servers with Managed Folders setup and am looking to see what properties are put on the folder and the items within.

    It looks like the folder is supposed to get this:

    PR_MANAGED_FOLDER_COMMENT
    PR_MANAGED_FOLDER_ID
    PR_MANAGED_FOLDER_INFORMATION

    And the item gets a tag 0x67170102  with a value for the time.

     

    My problem is one server is not working, and the other is, but when looking at the properties with MFCMAPI, I don;t see the PR attributes above, nor the 0X617 tag on the item for the one that is working.

    In the long run, I just want to confirm the properties are on the folder correctly, and the item has that tag - maybe I'm looking at the wrong place using MFCMAPI???

     

    Wednesday, July 27, 2011 1:34 PM

All replies

  • You might want to have a look at http://blogs.technet.com/b/dhardin/archive/2009/05/25/understanding-retention-periods-for-messaging-records-management-mrm.aspx which has some screen shots of how to use MFCMapi to view the elcmovedate (0X617 tag) which if MRM is working probably should be getting stamped on Items when the  Managed Folder Assistant runs . One thing to watch is make sure the Mapi profile you using in Online Mode (not cache mode) which can cause issues.  If your trying to diagnose a fault in this i would start with the Managed Folder Assistant logs (use get-mailboxserver to see the log location) and the Windows Application event log you can also start it manually using start-managedfolderassistant and see if anything gets logged.

    Cheers
    Glen 

    Thursday, July 28, 2011 6:33 AM