locked
contact selector (people picker) - configuration question (control become inactive right after name selection and no value placed)? RRS feed

  • Question

  • I configured a contact selector on my InfoPath 2007 form following all the usual instructions and even managed to place a default value in "DisplayName" to show current user name.
    When I preview a form it doesn't give me any errors. I can open a search window and search for a name without a problem. But when I select a name and click "OK" or right after I use "Check names" button, the field immediately grays out and become inactive and no value is being placed.
    What is causing this problem and what did I miss?

    Thanks!

    Monday, March 5, 2012 6:37 PM

Answers

  • Daniel,

    I found an error, and it is SO lame: I entered a field name AccountId as AccountID. Now it works.
    Sorry for your time and thanks a lot!

    Natalie

    • Marked as answer by Natalie Kash Wednesday, March 7, 2012 5:40 PM
    Wednesday, March 7, 2012 5:40 PM

All replies

  • Hi Natalie,

    Please double check all steps you followed in article(e.g. Using the Contact Selector Control) and re-configurate it, you can also check whether the Contact Selector control is added on non-repeating Group (e.g. gpContactSelector) containing the repeating group "Person" per the following similar post,

    http://www.infopathdev.com/forums/p/18183/63501.aspx

    Thanks


    Daniel Yang

    TechNet Community Support

    Wednesday, March 7, 2012 7:59 AM
    Moderator
  • Daniel,

    I found an error, and it is SO lame: I entered a field name AccountId as AccountID. Now it works.
    Sorry for your time and thanks a lot!

    Natalie

    • Marked as answer by Natalie Kash Wednesday, March 7, 2012 5:40 PM
    Wednesday, March 7, 2012 5:40 PM