none
Could not get the Microsoft Azure storage account settings

    Question

  • I'm trrying to publish an ASP.NET MVC project to azure. In other computer i do this without problems, but in mine I don't.

    The following error appears when publishing:

    Could not get the Microsoft Azure storage account settings for 'account-name' needed to configure an application module. Please check your network connection and verify that the account exists.

    Can anyone help me?

    Tks

    Thursday, September 17, 2015 2:01 PM

Answers

  • Visual Studio has a lot of problems with identity (don't get me started). Try setting the Azure subscription information before publishing the project. To do this, Click Tools > Connect to Microsoft Azure subscription. Then when you publish, make sure it's using the same account.

    Also make sure the storage account is in the same subscription you're trying to publish to.

    Robin

    Wednesday, September 30, 2015 12:52 AM

All replies

  • Hi Thevans,

    Thanks for posting here.

    Reset your Internet connection proxy settings.

    On a Windows machine, go to Control Panel / Internet Options / Connections tab / Lan Settings and change the proxy to Auto Detect. Save everything and try your deployment again.

    Hope this helps you.

    Girish Prajwal

    Thursday, September 17, 2015 5:39 PM
    Moderator
  • Hi Girish, thanks for your answer.
    But i have tryed that before anda don't work to.

    Thursday, September 17, 2015 6:09 PM
  • I would to go in IE, clear all cache information related to Azure account. Once this is done, restart VS and create a new deployment profile. Try to double check that you are using the right subscription.
    Friday, September 18, 2015 4:08 AM
  • Hi Radu.
    Don't work too :/
    Tuesday, September 22, 2015 1:19 PM
  • You could try to uninstall and install again VS and Azure Pack. Why kind of VS and SP you have for VS?

    We had a similar problem with VS2013 SP4 and even after a full uninstall and install of all resources we were not able to solve the problem.

    Friday, September 25, 2015 2:40 PM
  • Visual Studio has a lot of problems with identity (don't get me started). Try setting the Azure subscription information before publishing the project. To do this, Click Tools > Connect to Microsoft Azure subscription. Then when you publish, make sure it's using the same account.

    Also make sure the storage account is in the same subscription you're trying to publish to.

    Robin

    Wednesday, September 30, 2015 12:52 AM