none
Is it safe to delete the office 2010 MSOCache folder? RRS feed

  • Question

  • I would like to remove the MSOCache folder. It is taking up almost 700 mb and I need the space. It does not appear as an option in the Disk Cleanup utility. Is it OK to just delete it?

    Thanks,

    Matthew

    Tuesday, August 7, 2012 2:28 PM

Answers

  • According to this Microsoft article, 'Never delete MSOCache with Windows Explorer'. However it suggests alternate means.

    Edit: That may not work for versions of Office other than 2003. I found the same as you. I think the only 'safe' thing is to move the folder and adjust registry entries, as described here. However, I personally just tried deleting it, with Word 2007 installed, and Word still works fine. From several forum posts, and this article, I believe as long as you're prepared to put the disc back in if/when you need to repair, and possibly update, Office, then it is okay to delete it. But my personal opinion is not in line with 'official' Microsoft advice.

    • Edited by JosephFox Tuesday, August 7, 2012 7:04 PM
    • Marked as answer by macfarmw Tuesday, August 7, 2012 8:49 PM
    Tuesday, August 7, 2012 6:33 PM

All replies

  • According to this Microsoft article, 'Never delete MSOCache with Windows Explorer'. However it suggests alternate means.

    Edit: That may not work for versions of Office other than 2003. I found the same as you. I think the only 'safe' thing is to move the folder and adjust registry entries, as described here. However, I personally just tried deleting it, with Word 2007 installed, and Word still works fine. From several forum posts, and this article, I believe as long as you're prepared to put the disc back in if/when you need to repair, and possibly update, Office, then it is okay to delete it. But my personal opinion is not in line with 'official' Microsoft advice.

    • Edited by JosephFox Tuesday, August 7, 2012 7:04 PM
    • Marked as answer by macfarmw Tuesday, August 7, 2012 8:49 PM
    Tuesday, August 7, 2012 6:33 PM
  • Thanks, I moved it to a network share and updated the registry.
    Tuesday, August 7, 2012 8:49 PM