locked
Local SMTP Still Not Working RRS feed

  • Question

  •  I set every thing according to my friends posts in the following thread:

    http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010setup/thread/e9ce7f0a-288e-4ff7-a2f2-f1853229f49f

    To be more sure about it I set it to gmail instead of yahoo as in the article provided by Pentalogic.However in the event viewer I get the error:"Cannot connect to SMTP host myserver.mydomain.com".In Workflow Status Page I get the error:    "The e-mail message cannot be sent. Make sure the outgoing e-mail settings for the server are configured correctly" .About my settings in the IIS Advanced Delivery I set Fully Qualified Domain Name to MyServer.mydomain.com (If I put smtp.mydomain.com and click 'Check DNS' I get a message the domain name is not valid ) and in SharePoint OutGoing Settings I set Outbound SMTP Server to MyServer.mydomain.com too.About gmail settings I observed it has IMAP which I enabled to be sure every thing is OK.I tried telnet and it is working I think the problem is in my settings.By the way I observed IIS 7 also have SMTP settings which are empty so I set it to something similar to IIS 6 settings.I set its Authentication to 'Not Required'.   


    I am too late but i will never give up
    Thursday, October 20, 2011 10:14 AM

Answers

  • Only in SharePoint should you be setting the Outgoing mail settings to localhost.  Otherwise, follow the guide for the IIS SMTP config posted in your other thread.

    http://sharepoint.nauplius.net
    Saturday, October 22, 2011 10:20 PM

All replies

  • The error you're getting from the Workflow is sending email to the IIS SMTP server.  Is your IIS SMTP server on the same server as SharePoint?  If so, point the SharePoint Outgoing Email settings to localhost.  Validate that IIS SMTP will accept connections from localhost.
    http://sharepoint.nauplius.net
    Saturday, October 22, 2011 4:52 PM
  • The error you're getting from the Workflow is sending email to the IIS SMTP server.  Is your IIS SMTP server on the same server as SharePoint?  If so, point the SharePoint Outgoing Email settings to localhost.  Validate that IIS SMTP will accept connections from localhost.
    http://sharepoint.nauplius.net

    What about the Fully Qualified Domain Name in the IIS Advanced Delivery ? should I set it to localhost to? 
    I am too late but i will never give up
    Saturday, October 22, 2011 6:48 PM
  • Only in SharePoint should you be setting the Outgoing mail settings to localhost.  Otherwise, follow the guide for the IIS SMTP config posted in your other thread.

    http://sharepoint.nauplius.net
    Saturday, October 22, 2011 10:20 PM