none
Problem with .NET Framework 4 RRS feed

  • Question

  • Hello,

    I bought a software using the .NET framework 4.0 and I have problems to install it. I tried then to installed manualy .NET Framework 4.0 from the Microsoft Download link but it doesn't work. I have an error message saying that there is a "irremediable error". I tried then to uninstall .NET Framework 4 from my computer, but, it is impossible to do. I have again the same message... What can I do?

    I have Windows 7 Premium Familial Edition with SP1.

    Thanks a lot for your help,

    Best Regards

    Cyril

    Monday, December 31, 2012 3:56 PM

Answers

All replies

  • Hi Cyril,

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    Please use this verification tool to show us the current state of your .NET Framework 4.0:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET 4.0 selected, then post the first 15 lines AND last 15 lines of tool output here.

    If the verification fails, that means your .NET 4.0 installation is corrupt. If you reinstall 4.0 and it verifies OK, then goes corrupt after a reboot, that typically is symptomatic of OS issues which will require an OS reinstall to correct.

    Please try uninstall the .NET 4.0 from control panel and Installing the .NET Framework 4.

    If you have any questions, please feel free to let us know.

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, January 1, 2013 5:23 AM
    Moderator
  • Hello,

    Thanks for support. I have problem to use Skydrive. When I connect, a window appear to use Silverlight, it freezes completely Internet Explorer....

    Here the lines :

    [01/01/13,15:59:13] Beginning of new SetupVerifier activity logging session
    [01/01/13,15:59:13] Activity log file location: C:\Users\Cyril\AppData\Local\Temp\setupverifier_main_01-01-13_15.59.13.txt
    [01/01/13,15:59:13] Error log file location: C:\Users\Cyril\AppData\Local\Temp\setupverifier_errors_01-01-13_15.59.13.txt
    [01/01/13,15:59:13] Build created on September 10, 2012
    [01/01/13,15:59:13] Detected operating system: Windows 7 (x64)
    [01/01/13,15:59:13] For more information about repairing the .NET Framework, see ........
    [01/01/13,15:59:13] Install state for .NET Framework 1.0: not installed.
    [01/01/13,15:59:13] Install state for .NET Framework 1.1: not installed.
    [01/01/13,15:59:13] Install state for .NET Framework 2.0: installed with service pack 2.
    [01/01/13,15:59:13] Install state for .NET Framework 3.0: installed with service pack 2.
    [01/01/13,15:59:13] Install state for .NET Framework 3.5: installed with service pack 1.
    [01/01/13,15:59:13] Install state for .NET Framework 4 Client: installed with no service packs.
    [01/01/13,15:59:13] Install state for .NET Framework 4 Full: not installed.
    [01/01/13,15:59:13] Install state for .NET Framework 4.5: not installed.
    [01/01/13,15:59:13] Windows directory: C:\Windows

    ----------------------------------------------------------------------------------------------------------------------------------------------------------

    [01/01/13,15:59:38] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Client
     Value: Version
     Actual Data: REGISTRY VALUE FOUND
    [01/01/13,15:59:38] Section [Registry - .NET Framework 4 Client (Wow6432Node)] - stop parsing entries
    [01/01/13,15:59:38] Processing custom action 'Custom Action - .NET Framework 4.0 test application'
    [01/01/13,15:59:38] ExecutablePath = 'Netfx40TestApplication.exe'
    [01/01/13,15:59:38] FriendlyName = '.NET Framework 4 test application'
    [01/01/13,15:59:38] TimeoutSeconds = '300'
    [01/01/13,15:59:38] WaitOnExit = 'true'
    [01/01/13,15:59:38] Silent = 'true'
    [01/01/13,15:59:38] Launching process 'Netfx40TestApplication.exe' now
    [01/01/13,15:59:38] Process successfully launched. Waiting 300 seconds for it to complete.
    [01/01/13,15:59:40] Process 'Netfx40TestApplication.exe' exited with return code 0
    [01/01/13,15:59:40] Verification succeeded for product .NET Framework 4 Client

    Does it helps?

    Best Regards

    Tuesday, January 1, 2013 3:05 PM
  • Hi Again,

    I tried to uninstall the .NET Framework 4 from my computer but it failed....

    Please, note also that I had to remove the internet links which where is the lines of my previous message, they were not accepted here.

    Regards

    Tuesday, January 1, 2013 3:08 PM
  • Hi Cyril,

    From your log, we can see the .Net Framwork 4.0 full is not installed.

    Please install it from http://www.microsoft.com/en-us/download/details.aspx?id=17718

    After installing the .Net Framwork 4.0 full, can your program work now?

    If you have any questions, please feel free to let us know.

    Edit: Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like SkyDrive, and post the link here.

    I want to check what caused you failed to uninstall the .Net Framework.

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    Wednesday, January 2, 2013 7:50 AM
    Moderator
  • Dear Ego,

    Thanks for your message.

    The problem is that I can't install .NET Framework 4, I have always a failure and a message : "irremediable error".

    When I click on the download link everything looks fine. But, when I want to run the .exe installation file, a window open. What is stange here is that the size of the file is 0MB.... and not the 48.1MB... If I click on INSTALL at this stage, it starts to extract and then the problem occur.

    How can I send you the log file? I am not able to connect to SKYDRIVE because I have a problem also with SilverLight.

    Does it help?

    Regards

    Cyril

    Wednesday, January 2, 2013 9:50 AM
  • Ego,

    I am not able to send you a link to the log file, I have a message like what I can't send link or picture because my account has not been verified....

    That's realy crazy...

    Regards

    Cyril

    Wednesday, January 2, 2013 10:01 AM
  • Hi Cyril,

    I think you can send these log file to my e-mail:xxx

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.


    Friday, January 4, 2013 6:15 AM
    Moderator
  • Hi Ego,

    I sent you the log file by email!

    Many thanks,

    Cyril

    Monday, January 7, 2013 5:17 PM
  • Hi Cyril,

    I have check the logs and I found the error message:

    Error 0x80070424: Failed to open the current cluster

    I found two workarounds you can try:

    First workaround:

    - Download dotNetFx40_Full_x86_x64.exe from http://www.microsoft.com/en-us/download/details.aspx?id=17718
    - Launch commandline prompt as administrator
    - cd (change directory) commandline to location of downloaded dotNetFx40_Full_x86_x64.exe
    - Ran the command: dotNetFx40_Full_x86_x64.exe /x
    - Specified a location to extract when prompted
    - cd commandline to location of extracted files
    - Ran the command: RGB9Rast_x86.msi
    - Ran the command: netfx_Core_x86.msi EXTUI=1
    - Ran the command: netfx_Extended_x86.msi EXTUI=1

    Second workaround:

    Check whether or not windows installer’s service was started. If not, please start this service and try it again. If yes, please stop and restart this service and install .Net Framework again.

    More information you can refer to:

    http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/d2a454bf-b214-4dab-977c-6bc9355ddf67

    http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/0a56de6c-7240-4ac5-afd0-7abd0546a08c

    If they doesn't work, please feel free to let us know.

    Best regards,


    Ego [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, January 8, 2013 6:28 AM
    Moderator
  • Hi Ego,

    It looks it was successfull! I could installed my software and it runs!

    Many thanks for your precious help and support

    Best Regards

    Cyril

    Friday, January 11, 2013 2:29 PM