locked
Visual Studio 2017 XamarinInspectorPackage package did not load correctly RRS feed

  • Question

  • User315191 posted

    Related: https://forums.xamarin.com/discussion/85275/visual-studio-2015-inspectorpackage-package-did-not-load-correctly I was working just fine yesterday but when I tried to open my solution today I got this error. How do I fix this?

    Log:

    745 Warning VisualStudio Unexpected system error mode before loading package [XamarinInspectorPackage] {91D3BF5A-049A-4C78-AF4B-9AC149ADD84B} 746 Information VisualStudio Begin package load [XamarinInspectorPackage] {91D3BF5A-049A-4C78-AF4B-9AC149ADD84B} 747 Error VisualStudio LegacySitePackage failed for package [XamarinInspectorPackage]Source: '' Description: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (EINVALIDARG)) System.ArgumentException: The parameter is incorrect. (Exception from HRESULT: 0x80070057 (EINVALIDARG)) at EnvDTE.SolutionBuild.getStartupProjects() at Xamarin.VisualStudio.Inspector.XamarinInspectorPackage.GetStartupProject() in C:\d\lanes\4699\fec6f88f\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\XamarinInspectorPackage.cs:line 272 at Xamarin.VisualStudio.Inspector.XamarinInspectorPackage.RefreshInspectorSession() in C:\d\lanes\4699\fec6f88f\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\XamarinInspectorPackage.cs:line 132 at Xamarin.VisualStudio.Inspector.XamarinInspectorPackage.Initialize() in C:\d\lanes\4699\fec6f88f\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\XamarinInspectorPackage.cs:line 99 at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp) {91D3BF5A-049A-4C78-AF4B-9AC149ADD84B}


    80070057 - EINVALIDARG 748 Error VisualStudio SetSite failed for package XamarinInspectorPackage {91D3BF5A-049A-4C78-AF4B-9AC149ADD84B}
    80070057 - EINVALIDARG
    749 Error VisualStudio End package load [XamarinInspectorPackage] {91D3BF5A-049A-4C78-AF4B-9AC149ADD84B}
    80070057 - E
    INVALIDARG

    Thursday, August 31, 2017 12:59 PM

All replies

  • User73391 posted

    Hi! Can you go to Help -> About Visual Studio and let me know what version of the Xamarin extension is installed?

    I believe this is fixed in Xamarin 4.7 (which will be part of VS 15.4).

    I believe this can be worked around by disabling Lightweight Solution Load (https://docs.microsoft.com/en-us/visualstudio/extensibility/lightweight-solution-load-extension-impact). If that doesn't work, go into the Visual Studio Installer and completely remove "Xamarin Workbooks" to prevent the Inspector extension from doing any work when you next launch VS.

    Thursday, August 31, 2017 2:37 PM
  • User315191 posted

    Thanks for the quick response. It says that I'm running 4.5.0.486. I'll try the workaround.

    Do you think the fix will be backported? Doing a minor upgrade pose a great risk as, by experience, there's usually regressions being introduced that cause more trouble.

    Thursday, August 31, 2017 2:46 PM
  • User73391 posted

    Unfortunately, this fix was not approved for backporting.

    If you do disable Lightweight Solution Load, and the bug still occurs, please let me know, as that could indicate it's actually a new bug.

    Thursday, August 31, 2017 2:49 PM
  • User282264 posted

    Lightweight Solution Load NOT enabled here.

    I get the same error using Visual Studio 15.4.0 Preview 1.0

    No error using Visual Studio 15.3.2

    Wednesday, September 6, 2017 5:42 PM
  • User73391 posted

    @MartinGarins you get the same ArgumentException from get_StartupProjects()?

    Wednesday, September 6, 2017 5:44 PM
  • User282264 posted

    No I don't.

    747 Error VisualStudio LegacySitePackage failed for package [XamarinInspectorPackage]Source: 'Xamarin.VisualStudio.Inspector' Description: Value cannot be null. Parameter name: remoteServerProvider System.ArgumentNullException: Value cannot be null. Parameter name: remoteServerProvider at Xamarin.VisualStudio.Inspector.VSInspectorSession..ctor(Project proj, IRemoteServerProvider remoteServerProvider, IServiceProvider serviceProvider) in C:\d\lanes\5156\ddd8750f\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\VSInspectorSession.cs:line 59 at Xamarin.VisualStudio.Inspector.XamarinInspectorPackage.RefreshInspectorSession() in C:\d\lanes\5156\ddd8750f\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\XamarinInspectorPackage.cs:line 199 at Xamarin.VisualStudio.Inspector.XamarinInspectorPackage.Initialize() in C:\d\lanes\5156\ddd8750f\source\xamarinvs\src\Features\VisualStudio.Inspector\Vsix\XamarinInspectorPackage.cs:line 112 at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp) {91D3BF5A-049A-4C78-AF4B-9AC149ADD84B}


    80004003 - EPOINTER 748 Error VisualStudio SetSite failed for package XamarinInspectorPackage {91D3BF5A-049A-4C78-AF4B-9AC149ADD84B}
    80004003 - E
    POINTER

    Wednesday, September 6, 2017 6:08 PM
  • User73391 posted

    @MartinGarins thanks for checking. That's a different bug that is fixed in 15.4 preview 3.

    Wednesday, September 6, 2017 6:19 PM
  • User282264 posted

    No problem. You are welcome.

    Wednesday, September 6, 2017 6:22 PM
  • User61050 posted

    Lightweight Solution Load NOT enabled here.

    I get the same error using Visual Studio 15.4.0 Preview 2.0

    Any idea when Preview 3 will be available? Or a work around fix?

    Tuesday, September 12, 2017 2:13 PM
  • User73391 posted

    Preview 3 and 4 are already released, so closing this.

    Friday, October 6, 2017 4:21 PM