none
Microsoft API (FindFirstVolumeMountPoint) issue in Windows 2008? RRS feed

  • Question

  • Greetings,

    we are experiencing the "old" issue with mountingpoints during the backups and the output always does advise error 5 Access Denied .

    Here is the tracelog from a backup tool:

    14.08.2015 21:40:34.295 [011660] [11076] : ..\..\common\winnt\psfsinfo.cpp(1852): GetDosDevTrueName(): Querying DOS Device name for szDosDevName = 'C:' ...
    14.08.2015 21:40:34.295 [011660] [11076] : ..\..\common\winnt\psfsinfo.cpp(1859): GetDosDevTrueName(): Dos Device name is '\Device\HarddiskVolume2'
    14.08.2015 21:40:34.295 [011660] [11076] : ..\..\common\winnt\psfsinfo.cpp( 835): Calling QueryVolMountPoints()
    14.08.2015 21:40:34.295 [011660] [11076] : ..\..\common\winnt\reparse.cpp( 579): Entering QueryVolMountPoints()
    14.08.2015 21:40:34.296 [011660] [11076] : ..\..\common\winnt\reparse.cpp( 580):    mountEntryP = 0x4e2288
    14.08.2015 21:40:34.296 [011660] [11076] : ..\..\common\winnt\reparse.cpp( 581):    vol         = <C:\>
    14.08.2015 21:40:34.296 [011660] [11076] : ..\..\common\winnt\reparse.cpp( 582):    hMount      = 0x0
    14.08.2015 21:40:34.296 [011660] [11076] : ..\..\common\winnt\reparse.cpp( 583):    rootVolGUID = <\\?\Volume{a2d8e1f8-3b3b-11e5-93f0-806e6f6e6963}\>
    14.08.2015 21:40:34.296 [011660] [11076] : ..\..\common\winnt\psfsinfo.cpp(1778): GetDosDevTrueName() called. INPUT drv = 'C:\'
    14.08.2015 21:40:34.296 [011660] [11076] : ..\..\common\winnt\psfsinfo.cpp(1852): GetDosDevTrueName(): Querying DOS Device name for szDosDevName = 'C:' ...
    14.08.2015 21:40:34.297 [011660] [11076] : ..\..\common\winnt\psfsinfo.cpp(1859): GetDosDevTrueName(): Dos Device name is '\Device\HarddiskVolume2'
    14.08.2015 21:40:34.317 [011660] [11076] : ..\..\common\winnt\reparse.cpp( 667): Returned from FindFirstVolumeMountPoint(), hMnt = 0xffffffff, szMntName = <>
    14.08.2015 21:40:34.317 [011660] [11076] : ..\..\common\winnt\reparse.cpp( 674): hMnt == INVALID_HANDLE_VALUE, Win32 RC = 5
    14.08.2015 21:40:34.317 [011660] [11076] : ..\..\common\winnt\reparse.cpp( 677): dwRC == 5
    14.08.2015 21:40:34.317 [011660] [11076] : ..\..\common\winnt\reparse.cpp( 689): QueryVolMountPoints(C:\): FindFirstVolumeMountPoint() Win32 RC = 5
    14.08.2015 21:40:34.317 [011660] [11076] : ..\..\common\ut\GlobalRC.cpp( 428): msgNum = 1996 changed the Global RC.

    It has suddenly started 22.-23.7.15 on all servers no matter the version of Backup Client and I was not able to find if there was some global Security fix or Service pack deployment.

    I remember that this case was to problem in Windows 2003 (https://support.microsoft.com/en-us/kb/934336) but it shows in all Windows servers versions up to 2012.

    Any suggestion how to trace the relevant security settings and where do dig? ;-)

    Thank you in advance for your support

    Wednesday, August 19, 2015 6:23 AM