none
Problem with XP and Word 2010 using CreateObject RRS feed

  • Question

  • I have an application, which creates an instance of word (visible=false), loads a document, fill in some data and close document & word.

    using:
    XP + Office2003/2007 --> this process needs between 2-5 sec
    Win7 + Office2003/2007/2010 --> also 2-5 sec
    XP + Office 2010 --> 2-3 MINUTES !!

    i have to use late binding for supporting different environments. [WordApp = CreateObject("Word.Application")]

    when i take a look to taskmanager, there are 2-3 MSIEXEC-processes, which are started with "CreateObject" and take a lot of time before the instance of WINWORD is created!?

    ANY HINTS?? THANK YOU!
    Thursday, January 20, 2011 6:38 PM

All replies

  • no one any idea ??? PLEASE :-(
    Saturday, January 22, 2011 1:34 PM
  • no one any idea ??? PLEASE :-(

    Not really as I don't have an XP+Word 2010 environment to test here at the moment, /but/ could this actually be one of the traditional problems where Word takes a long time to open a document, rather than simply because it's Word 2010+XP? e.g.
     a. it is attached to a template at a network address that does not exist
     b. the default printer is inaccessible
    (probably worth checking whether starting Word without opening the document takes 2-3 minutes).

    Peter Jamieson
    Saturday, January 22, 2011 3:11 PM
  • i think no, as word starts normal & fast if it is started via mouse-click.

    the problem only occurs, when word is started with OLE-automation from my .net-application (created with VS2003)

    i also tried to install the office 2010-PIA, but that changed nothing.

    :-(

     

    Saturday, January 22, 2011 3:57 PM
  • ist here a way to find out, why the msiexec-processes want to install or for what they are looking for?

    Monday, January 24, 2011 11:08 PM
  • I tested on my WinXP/Office2010 machine and I don't see the problem using late binding from Excel.  Can you try automating Word from Excel and see if you get the same problem?  That might help narrow down where we should be looking.

    Brandon

    Monday, January 31, 2011 5:29 AM
    Moderator
  • I think, i am getting crazy...

    1st: i tried it from Excel --> works fine !

    2nd: i removed the 2010-PIA from my computer again and then tried it again from my application --> HÄH??? NOW IT WORKS !!???

    Looks, like i am a fool .... I will give it a try at my customer ... there are more than one PC with the same problem.

    Thanks so far ...!

    Sigi

     

    Monday, January 31, 2011 8:38 AM