none
Activate wwan based connection through ndisuio in WEC7 RRS feed

  • Question

  • Hi,

    I have developed a RIL driver, and the internet conexion is made with Ndis (NdisGprs Ril_Ndis_SetGprsContextActivated. The driver is working OK, and I'm able to pass the data tests of WCETK. My problem is that I don't know how to configure this connection to use it, and not only in data test, because in the Network and Dial-Up connections only appears the ras dial option to setup.

    Do I have to configure my wwan connection in registry? Or do I have to program an application to rise the interface up, in this case, what do I have to use?

     

    Thank you,

     

    David

    Friday, October 28, 2011 4:11 PM

All replies

  • Hi,

    I am facing the similar problem, Any help around?

    Thursday, February 12, 2015 11:52 AM
  • What do you really need Internet connection or connection to CETK?

    To establish a RAS connection refer

    https://msdn.microsoft.com/en-us/library/ee496658(v=winembedded.70).aspx

    https://msdn.microsoft.com/en-us/library/ee498674(v=winembedded.70).aspx


    rakesh

    Thursday, February 12, 2015 2:30 PM
  • hi rakesh,

    I have updated my RIL in wince to support rndis, but i am not sure how to test it in wince.

    Thanks

    Friday, February 13, 2015 7:46 AM
  • I am Not sure about testing RIL with CETK7.

    You can write a sample test app to communicate with modem, then you can try establishing internet connection with RAS dial.

    you can refer the samples here:

    C:\WINCE700\public\common\oak\drivers\netsamp\rasdial

    C:\WINCE700\public\common\oak\drivers\netsamp\autoras


    rakesh

    Friday, February 13, 2015 2:01 PM
  • Hi Rakesh,

    Thank you for your advise, but arent the "rasdial" and "autoras" are for testing RIL when modem in connected in PPP mode.

    I want to test when RIL when modem is in NDIS mode.

    In simple words how can i hit the interface "Ril_Ndis_SetGprsContextActivated" which is asked in the first post by David.

    I really appreciate your help :)

    Tuesday, February 17, 2015 5:18 AM
  • Hi, I have faced the same issue. There should be a registry key in your RIL driver configurations.

    [HKEY_LOCAL_MACHINE\Comm\Cellular\RIL]
       "DisableNITZ"=dword:0 ; Enable/Disable NITZ
       "Packet"=dword:0     ; connection mode: 0=RAS-based, 1 or more=NDIS
       "Contexts"=dword:1   ; Concurrent PDP contexts

    The value of Pakcet needs to be set to 1 in order to hit Ril_Ndis_SetGprsContextActivated. I got this after a lot of stress!! Anyways, this should work otherwise you can contact me because i have my RNDIS working somehow.

    Best Regards

    Tuesday, May 5, 2015 10:43 AM