none
Trying to sign in using Skype in UI suppression mode. RRS feed

  • Question

  • I'm currently trying to sign into Skype with UI suppression mode enabled.

    For some customers this works correctly and Skype for business signs in. But for one office 365 client the sign in never completes and gets stuck.

    If I run the sign in with the UI not suppressed, I see the following pop-up appear:

    This pop-up seems to be blocking the SDK from signing in. Anyone know what is causing this or how to resolve it? Seems the SDK has a bug where it isn't providing the password to this pop-up window. If I enter the password I have manually the sign in completes.

    The code I'm using to sign in is:

    await Task.Factory.FromAsync((callback, stateObject) => _client.BeginSignIn(config.SkypeUserUri, config.SkypeDomainAndUsername, config.SkypePassword, callback, stateObject), _client.EndSignIn, null);

    Thanks,
    Max

    Sunday, December 9, 2018 5:38 AM

All replies

  • For anyone else this was resolved on SO:

    https://stackoverflow.com/questions/53518511/skype-for-business-login-popup

    This happens if: 1) ModernAuthentication is enabled in your office365 tenant 2) EnableADAL = 1 if you are using SkypeForBusiness2015 client 2015 3) If you are using SkypeForBusiness2016 client

    Applicable only to SfB prior to 2016 HKCU\SOFTWARE\Microsoft\Office\15.0\Common\Identity\EnableADAL If you want to bypass this pop-up, then you need to add EnableADAL registry key and set its value to 0.

    Wednesday, June 5, 2019 9:40 AM