locked
BAM Portal issue RRS feed

  • Question

  • Hello all,

    I have deployed my application from Dev server to Test server, I have creted view in BAMPrimary database.

    Also I am able to open the BAM portal and can see the web page but giving me error that there is not view to display on page.

    I have manualy check and can able to see the view which gives me data as well.

    I am having doubt that my user - user1 is not having rights to see this view that's why I am not able to see it in BAM Portal.Any thought about it ? what would be other posiblilites for this errors ?

    Any Help is welcome ...

    thanks,

    Nitin.


    Thanks and Regards, Nitin.

    Tuesday, September 9, 2014 1:03 PM

All replies

  • Your doubts are correct. The user does not have access to the view. As a rule after you deploy an activity you should use the "bm add-account" to give users permissions to the view.

    You can use the "bm get-accounts" on the view to check if your user has permissions.

    For a full list of BM commands refer "BAM Management Utility - User Management Commands" @http://msdn.microsoft.com/en-us/library/bb259989.aspx

    Regards.

    Tuesday, September 9, 2014 1:35 PM
  • From VS-Command prompt, browse to <installation path>\Program Files\Microsoft BizTalk Server %version%\Tracking folder. An executue the following command:

    bm.exe add-account -AccountName:DOMAIN\USER -View:YourViewName


    Where DOMAIN\USER = The user to whom you have to add/give access. In this case, it may be your account.

    YourViewName  = Your View name to which you want to add/give access


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.


    Tuesday, September 9, 2014 1:45 PM
  • I am executing command :

    echo Deploying activity.
    "%BMPATH%" update-all -DefinitionFile:ExceptionDetailsActivity.xml

    This command is giving me error as :

    ERROR: The BAM deployment failed.
    The alerts were not deployed.
    Cannot open BAMAlerts service on computer '.'.
    Access is denied


    Thanks and Regards, Nitin.

    Wednesday, September 10, 2014 12:51 PM
  • Different issue to the one this forum has been raised. Close this forum and raise this as another question. This would help others who search for similar issues.

    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    Wednesday, September 10, 2014 2:14 PM
  • You cannot vote on your own post                            
    0
                    

    Hello All,

    I am still having issue when deploying BAM view on Test server.

    I have created this view in Bam and it's working fine on Local (development box)

    Now I want to migrate this same view on Test server and I am executing this Batch file the command in batch file is as follows.

    C:\Deployment\Deployment_03092014\BAM>"C:\Program Files (x86)\Microsoft BizTalk
    Server 2013\Tracking\bm.exe" update-all -DefinitionFile:ExceptionDetailsActivity
    .xml
    Microsoft (R) Business Activity Monitoring Utility Version 3.11.158.0
    Copyright (C) Microsoft Corporation. All rights reserved.

    Using 'BAMPrimaryImport' BAM Primary Import database on server 'ServerName'...

    Updating Activity... Done.
    ERROR: The BAM deployment failed.
    The alerts were not deployed.
    Cannot open BAMAlerts service on computer '.'.
    Access is denied


    Thanks and Regards, Nitin.

    Friday, September 26, 2014 7:55 AM