none
Error Connecting to Database from IIS via WCF using Enterprise Library 6 RRS feed

  • Question

  • HI, i have and application with an WCF connecting to SQL Server via Interprise Libary 6.0. It Works fine, but when y upload to IIS it has a error messagge "The connection string for the database 'dbConnectionString' does not exist or does not have a valid provider."
    Im using Framework 4.5 and Windows 2012 R2.
    If I use SqlConnection it Works fine..
    Any ideas?
    Thanks

    Diego

    • Moved by Barry Wang Friday, November 29, 2013 8:24 AM WCF related
    Thursday, November 28, 2013 5:37 PM

All replies

  • Hi Diego,

    Your issue is related to WCF technology so I've moved it to the right forum.

    Regards,



    Barry Wang
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, November 29, 2013 8:24 AM
  • Hi,

    The following configuration taken from MSDN can be applied to enable tracing on your WCF service.

    <configuration>
      <system.diagnostics>
        <sources>
          <source name="System.ServiceModel"
                  switchValue="Information, ActivityTracing"
                  propagateActivity="true" >
            <listeners>
                 <add name="xml"/>
            </listeners>
          </source>
          <source name="System.ServiceModel.MessageLogging">
            <listeners>
                <add name="xml"/>
            </listeners>
          </source>
          <source name="myUserTraceSource"
                  switchValue="Information, ActivityTracing">
            <listeners>
                <add name="xml"/>
            </listeners>
          </source>
        </sources>
        <sharedListeners>
            <add name="xml"
                 type="System.Diagnostics.XmlWriterTraceListener"
                 initializeData="Error.svclog" />
        </sharedListeners>
      </system.diagnostics>
    </configuration>
    Friday, December 6, 2013 10:40 AM