locked
Window Phone emulator is not working RRS feed

  • Question

  • I have visual studio 2105 community version.

    When i try to debug a window phone app then window phone emulator is not opening properly.Every time it show the message that "window phone emulator is unable to connect to the window phone operating system  , unable to setup the UDP port, Some functionality might be disabled ".

    I tried everything that i find on the internet but none of them works.


    • Moved by Jiayi Li Friday, August 7, 2015 2:41 AM
    Thursday, August 6, 2015 9:03 AM

Answers

  • Hello kalpraj,

    First of all, please check that your emulator can get to internet, check your firewall and antivirus software.

    For example, if you have an antivirus software, open it and add UDP protocol to the antivirus software rules. Or just turn off your antivirus software to see the result. It may blocked the connection of the emulator.

    Sometimes you may also need to recreate a new emulator in hyper-v, please try the steps listed here:

    1.) Open Hyper-V

    2.) Shutdown any existing configured Phone emulators.

    3.) Click on "Virtual Switch Manager"

    4.) Click on the "Windows Phone Emulator Internal Switch"

    5.) Remember what the settings are displayed there (because you will delete it and recreate it)

    6.) Delete the existing "Windows Phone Emulator Internal Switch" by clicking "Remove"

    7.) Click "Apply" and "OK"

    8.) Re-create the "Windows Phone Emulator Internal Switch" by clicking the "New virtual network switch" and use the same settings you remembered in Step 5.

    Maybe the new created Emulator will fix this port issue.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, August 14, 2015 2:31 AM

All replies

  • Thank you for posting in MSDN forum.

    This forum is about Visual studio setup and installation, as your issue is about your windows phone emulator unable to connect, it would be related to Windows phone development, I help you move this case to Developing universal windows app forum for better assist.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    • Edited by Jiayi Li Friday, August 7, 2015 2:42 AM
    Friday, August 7, 2015 2:35 AM
  • Hello kalpraj,

    First of all, please check that your emulator can get to internet, check your firewall and antivirus software.

    For example, if you have an antivirus software, open it and add UDP protocol to the antivirus software rules. Or just turn off your antivirus software to see the result. It may blocked the connection of the emulator.

    Sometimes you may also need to recreate a new emulator in hyper-v, please try the steps listed here:

    1.) Open Hyper-V

    2.) Shutdown any existing configured Phone emulators.

    3.) Click on "Virtual Switch Manager"

    4.) Click on the "Windows Phone Emulator Internal Switch"

    5.) Remember what the settings are displayed there (because you will delete it and recreate it)

    6.) Delete the existing "Windows Phone Emulator Internal Switch" by clicking "Remove"

    7.) Click "Apply" and "OK"

    8.) Re-create the "Windows Phone Emulator Internal Switch" by clicking the "New virtual network switch" and use the same settings you remembered in Step 5.

    Maybe the new created Emulator will fix this port issue.

    Best regards,

    Barry


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, August 14, 2015 2:31 AM