none
USQL Problem getting Credentials for external SQL database

    Question

  • Hi!

    Im trying to do a CREATE DATA SOURCE in USQL, but I can't fetch the Credentials object from the ADLA catalog.

    I have created it using the new PowerShell approach at https://docs.microsoft.com/en-us/powershell/module/azurerm.datalakeanalytics/new-azurermdatalakeanalyticscatalogcredential?view=azurermps-5.0.0

    In this old days you could use CREATE CREDENTIALS, but this is deprecated. I need to create the MyCredentials object for putting on the CREDENTIALS=MyCredentials part of the CREATE DATA SOURCE statement.

    How is this done now that CREATE CREDENTIALS is deprecated?

    Thanks in advance.

    Best regards,

    Rasmus

    Thursday, November 23, 2017 2:15 PM

Answers

All replies

  • Did you follow the from CREATE DATA SOURCE (U-SQL) ?
    • Marked as answer by Rasmus Ursem Friday, November 24, 2017 11:11 AM
    Thursday, November 23, 2017 5:20 PM
  • Strange - it works now when I compile against the online Data Lake Analytics Account (the dropdown atop the USQL script in VS2017).

    I followed the guide you mention, but it gave a wierd compile error mentioning something about OPTION ; near the point in the code where the credentials were. This was gone about 90 minutes after I posted, so maybe it was some latency issue?!

    Anyway, the problem is solved. Thanks for replying!

    Friday, November 24, 2017 11:11 AM