locked
Problems with Design tab RRS feed

  • Question

  • We are a small team of developers and one developer has moved to VS 2012, the others are using VS2010 and TeamFoundationServer.  We all have .Net FW 4.0, Silverlight 5.0 and Telerik Rad controls and Reporting installed.

    When attempting to view the Degisn Tab in the XAML, it returns this error/msg:

    Problem Loading

    The document contains errors that must be fixed before the designer can be loaded. Reload the desigher after you have fixed the errors.  The Help does not open, so if I click Reload the designer I get the following error messages.

    NullReferenceException was thrown due to document error: The type initializer for 'Microsoft.Expression.Platform.Silverlight.Metadat.FrameworkElementMetadata' threw an exception Unhandled Exception has occured Object reference not set to and instance of an object at Microsoft.Expression.Platform.Silverlight.Metadat.FrameworkElementMetadata..cctor(). 

    It only happens on some of the projects within the whole solution.  Does anyone have a clue as to how to fix it?  The developer with VS2012 has the same issue, but with different projects within the solution.

    Thanks for any help you might offer.

    Wednesday, October 10, 2012 3:59 PM

Answers

All replies

  • The XAML designer fails very easily because it is based on the markup (xaml) which can contain many errors/typos.

    Does the application run fine though?

    If you have no clue where to start, you can try the following:

    1. Look for any red underlined sections in the xaml which might highlight the problem.

    2. You can comment out the bulk of the xaml file, rebuild and see if at least an empty page works, then from there you can comment the parts back one by one until you can identify which element is the real problem. (This is sometimes the only way)

    3. Common problems include the way you declare xml namespaces at the top of the XAML file. The "xmlns:xxxx" declarations are VERY strict. If you move controls around, you must be very careful to adjust those declarations correctly.

    There are many other causes, so try these suggestions and see what they do for you. Or if you can rebuild fresh again and see if you get a better error message or any clues as to why the designer fails.

    Let me know what you find.

    Thursday, October 11, 2012 5:58 PM
  • The answere was to rename the folder to have SP2 on the end, mine was named SP1 and some others on the team said theirs was blank on the end

    C:\Program Files (x86)\Telerik\RadControls for Silverlight Q2 2012 SP2

    The answer was in this post.  How the fellow found that it was a rename issue is beyond me.

     http://www.telerik.com/community/forums/silverlight/general-discussions/major-issue-with-2012-2-0912.aspx

    Thanks for trying to help me!

    Friday, October 12, 2012 8:27 PM