locked
Central Administration Inaccessible After Initial Setup RRS feed

  • Question

  • After running the configuration wizard (successfully, according to the wizard) to attempt setup of the first server in our farm, the central administration site is inaccessible. When I attempt to navigate to the site it prompts me for a username and password once, I enter the AD account from which I ran the config utility and then it kicks me to a page not found error. I have tried this with the same results on different boxes though always connecting to the same database. I am not sure what to try next so any help would be greatly appreciated!

    The only error that I can find is in the Application log but I do not know if it is relevant:
    Application Server Administration job failed for service instance Microsoft.Office.Server.Search.Administration.SearchAdminSharedWebServiceInstance
    Thursday, August 28, 2008 2:12 PM

Answers

  • Finally found the solution to our problem today. Apparently the HTTP Keep-Alives setting needs to be enabled when "Enable Anonymous Access" is unchecked. The setting is on the Web Site tab in IIS properties.

    Thursday, August 28, 2008 9:52 PM
  • Ok, I'm in and I can tell you this has NOT been fun lol.  Apparently I had left networkservice as the application pool identity because it was recommended in a technet article I read.....I just arbitrarily changed that to localsystem and boom, it let me in.

    I hope the rest is easier!!  Get use to seeing me mod's.
    Friday, August 29, 2008 4:22 PM

All replies

  • One note, I have attempted this with both kerberos (our desired configuration) and with NTLM to rule that out as an issue.
    Thursday, August 28, 2008 3:02 PM
  • Check IIS and the Application Pools. Make sure you're using the same account as the CA App Pool to log in.

    Good luck.
    Thursday, August 28, 2008 7:11 PM
  • I am having the same issue, of a sort:  I have installed Server 2008, IIS 7, and SQL 2005 (w/SP2).  I then installed MOSS 2007 and everything has gone smoothly UNTIL, it finished the configuration and tried to pull up Central Admin for the first time.   I was getting an HTTP: services unavailable error, and after much searching managed to :

    Make local Network Service the default for the application pool, and added it to the WSS_ADMIN_WPG, WSS_WPG goups.  I then was getting a page of "don't have rights to the web.config" so I added network service in there (even though the groups were already in there as having rights).  Still got the no access to web.config page.  I then added it to the IIS_USRS group, and now am getting the same thing mdorison is getting, the login prompt.  When I put in the admin account (test server, test domain)  I am getting a "can not connect to configuration database" message.  Admin account is in all these same groups, not to mention I added it on top of everything else to everywhere I can think of.

    I'm fried................any help out there?   
    Thursday, August 28, 2008 9:33 PM
  • Finally found the solution to our problem today. Apparently the HTTP Keep-Alives setting needs to be enabled when "Enable Anonymous Access" is unchecked. The setting is on the Web Site tab in IIS properties.

    Thursday, August 28, 2008 9:52 PM
  • That actually isn't the case for me since I'm using IIS 7, though 6 did install for some reason it is not tied to the application pool.  I've disable IPv6 (seems like I saw that somewhere) and I'm still getting "can not connect to configuration database".

    Any help would be extremely appreciated.
    Friday, August 29, 2008 3:56 PM
  • Ok, I'm in and I can tell you this has NOT been fun lol.  Apparently I had left networkservice as the application pool identity because it was recommended in a technet article I read.....I just arbitrarily changed that to localsystem and boom, it let me in.

    I hope the rest is easier!!  Get use to seeing me mod's.
    Friday, August 29, 2008 4:22 PM